google_api_availability 2.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 95

Flutter Google Api Availability Plugin #

pub package

A Flutter plugin to check the availability of Google Play services on the current device.

BranchBuild Status
developBuild Status
masterBuild Status

Features #

  • Check the availability of Google Play services (on Android only).

Usage #

To use this plugin, add google_api_availability as a dependency in your pubspec.yaml file. For example:

dependencies:
  google_api_availability: '^2.0.0'

NOTE: There's a known issue with integrating plugins that use Swift into a Flutter project created with the Objective-C template. See issue Flutter#16049 for help on integration.

API #

GoogleApiAvailability #

To check the availability of Google Play services on the current device, you can use the checkGooglePlayServicesAvailability method. This could be helpful to provide a more friendly experience to users in case an user-action is required to enable support for Google Play services (More information can be found here).

import `package:google_api_availability/google_api_availability.dart`;

GooglePlayServicesAvailability availability = await GoogleApiAvailability().checkGooglePlayServicesAvailability();

If you want to show a dialog by the Android system with more information and show a possible fix to the user you can do:

import `package:google_api_availability/google_api_availability.dart`;

GooglePlayServicesAvailability availability = await GoogleApiAvailability().checkGooglePlayServicesAvailability(true);

Note that on iOS this will always return false!

See also the example project for a complete implementation.

Issues #

Please file any issues, bugs or feature request as an issue on our GitHub page.

Want to contribute #

If you would like to contribute to the plugin (e.g. by improving the documentation, solving a bug or adding a cool new feature), please carefully review our contribution guide and send us your pull request.

Author #

This Google Api Availability plugin for Flutter is developed by Baseflow. You can contact us at hello@baseflow.com

2.0.1 #

  • No longer rely on the Activity object when this plugin is instantiated.

2.0.0 #

  • Move from swift to Objective-C and from Kotlin to Java

1.0.6+1 #

  • Revert the breaking 1.0.6 update. 1.0.6 was known to be breaking and should have incremented the major version number instead of the minor. This revert is in and of itself breaking for anyone that has already migrated however. Anyone who has already migrated their app to AndroidX should immediately update to 2.0.0 instead. That's the correctly versioned new push of 1.0.6.

1.0.6 #

  • BAD. This was a breaking change that was incorrectly published on a minor version upgrade, should never have happened. Reverted by 1.0.6+1.

"Breaking change. Migrate from the deprecated original Android Support Library to AndroidX. This shouldn't result in any functional changes, but it requires any Android apps using this plugin to also migrate if they're using the original support library."

1.0.5 #

  • BAD. This was a breaking change that was incorrectly published on a minor version upgrade, should never have happened. Reverted by 1.0.6+1.

"Breaking change. Migrate from the deprecated original Android Support Library to AndroidX. This shouldn't result in any functional changes, but it requires any Android apps using this plugin to also migrate if they're using the original support library."

1.0.4 #

  • Update used Kotlin and Gradle versions.

1.0.3 #

  • Bug fix that is introduced due to breaking changes in Flutter version 0.9.6.

1.0.2 #

  • Add additional iOS configuration to make sure it compiles correcty using Swift 4.1

1.0.1 #

  • Add iOS implementation that returns false

1.0.0 #

  • Initial release

example/README.md

google_api_availability_example #

Demonstrates how to use the google_api_availability plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  google_api_availability: ^2.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:google_api_availability/google_api_availability.dart';
  
Version Uploaded Documentation Archive
2.0.1 May 17, 2019 Go to the documentation of google_api_availability 2.0.1 Download google_api_availability 2.0.1 archive
2.0.0 Feb 20, 2019 Go to the documentation of google_api_availability 2.0.0 Download google_api_availability 2.0.0 archive
1.0.6+1 Feb 20, 2019 Go to the documentation of google_api_availability 1.0.6+1 Download google_api_availability 1.0.6+1 archive
1.0.6 Feb 13, 2019 Go to the documentation of google_api_availability 1.0.6 Download google_api_availability 1.0.6 archive
1.0.5 Feb 12, 2019 Go to the documentation of google_api_availability 1.0.5 Download google_api_availability 1.0.5 archive
1.0.4 Oct 10, 2018 Go to the documentation of google_api_availability 1.0.4 Download google_api_availability 1.0.4 archive
1.0.3 Oct 5, 2018 Go to the documentation of google_api_availability 1.0.3 Download google_api_availability 1.0.3 archive
1.0.2 Sep 18, 2018 Go to the documentation of google_api_availability 1.0.2 Download google_api_availability 1.0.2 archive
1.0.1 Sep 17, 2018 Go to the documentation of google_api_availability 1.0.1 Download google_api_availability 1.0.1 archive
1.0.0 Sep 4, 2018 Go to the documentation of google_api_availability 1.0.0 Download google_api_availability 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
92
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
95
Overall:
Weighted score of the above. [more]
95
Learn more about scoring.

We analyzed this package on Jun 25, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test