go_router 14.2.1 copy "go_router: ^14.2.1" to clipboard
go_router: ^14.2.1 copied to clipboard

A declarative router for Flutter based on Navigation 2 supporting deep linking, data-driven routes and more

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add go_router

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  go_router: ^14.2.1

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:go_router/go_router.dart';
4520
likes
160
pub points
100%
popularity

Publisher

verified publisherflutter.dev

A declarative router for Flutter based on Navigation 2 supporting deep linking, data-driven routes and more

Repository (GitHub)
View/report issues
Contributing

Topics

#deep-linking #go-router #navigation

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

collection, flutter, flutter_web_plugins, logging, meta

More

Packages that depend on go_router