git2 0.0.3

git2 #

A libgit2 wrapper.

This is an initial work on a libgit2 wrapper with dart:ffi which so far only implements a few methods to figure out how to setup a dart:ffi package. Therefore it does not have any API stability guarantees. Comments, tips and merge request are welcome!

license #

This libgit2 wrapper is licensed under the 3 clause BSD license. But beware of the differing license of the wrapped libgit2 library.

0.0.3 #

  • Add example code and fix remaining linter errors

0.0.2 #

  • Fix linter errors and warnings for better project health

0.0.1 #

  • Initial release to get the ball rolling.

example/example.dart

// SPDX-License-Identifier: BSD-3-Clause

import 'package:git2/git2.dart';

void main() {
  final repo = GitRepository.open('.');
  final workdir = repo.workdir();
  print('The repository working directoy is: $workdir');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  git2: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:git2/git2.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Feb 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
ffi ^0.1.3 0.1.3
Dev dependencies
test ^1.9.4