git 0.1.0-dev

  • Readme
  • Changelog
  • Installing
  • 37

BOT!

The Dart Bag-of-Tricks #

A collection of (mostly) general libraries to make working with Dart more productive. #

Build Status

Projects using bot_io #

Try It Now #

The Dart Bag-of-Tricks ( BOT ) is hosted on pub.dartlang.org. Add the bot_io package to your pubspec.yaml file, selecting a version range that works with your version of the SDK. Always check the bot_io page on pub to find the latest release.

See the changelog to find the version that works best for you.

If you'd like to track bleeding edge developments, you can reference the the GitHub repository directly:

dependencies:
  bot:
    git: https://github.com/kevmoo/bot_io.dart.git

Versioning #

  • We follow Semantic Versioning.
  • We are not planning a V1 for bot_io until Dart releases V1.
    • In the mean time, the version will remain 0.Y.Z.
    • Changes to the minor version - Y - will indicate breaking changes.
    • Changes to the patch version - Z - indicate non-breaking changes.

Dart SDK dependency #

  • We're going to try to keep bot_io in line with the latest integration build of the Dart SDK and Editor.
  • At this point, each SDK release tends to introduce breaking changes, which usually require breaking changes in bot_io.
  • Keep an eye on the changelog to see how bot_io aligns with each SDK release.

The libraries #

bot_io -- default library #

bot_git #

Authors #

Changelog - Dart Bag of Tricks - IO #

0.25.1 2013-12-10 (SDK 1.0.2.1 r30821) #

  • DEPRECATED expandStream. You likely weren't using it anyway. If you were, it's in bot now.
  • A bunch of test clean-up.
  • Dependency tweaks.

0.25.0 2013-11-07 (SDK 0.8.10+6 r30036) #

0.24.0 2013-10-31 (SDK 0.8.9 r29656) #

  • Updates for latest SDK
  • BREAKING changes to tryCompletion and the completion generator due to removal of Options from dart:io.

0.23.3 2013-10-24 (SDK 0.8.6 r29156) #

  • Updates for latest SDK

0.23.2 2013-08-26 (SDK 0.6.21.2 r26619) #

  • Updates for latest SDK

0.23.1 2013-07-26 (SDK 0.6.9.2 r25388) #

  • NEW! TempDir.then - for those times when you just want a directory.
  • Tiny updates to dependencies, refactoring in bot_git

0.23.0 2013-07-24 (SDK 0.6.9.2 r25388) #

  • Latest SDK
  • BREAKING Moved completion into its own library.

0.22.0 2013-07-18 (0.6.5.0 r25017) #

  • Updated min SDK to 0.6.5
  • Moved from 'pathos' to 'path' package
  • DEPRECATED DirectoryPopulater and MapDirectoryPopulater
  • BREAKING TempDir.populate now takes the same inputs as EntityPopulater.populate

0.21.3 2013-07-11 (SDK 0.6.3.3 r24898) #

0.21.2 2013-06-04 (SDK 0.5.13.1 r23552) #

  • Fixes for SDK 0.5.13.1
  • Crypto moved to a pub package

0.21.1 2013-05-28 (SDK 0.5.11.1 r23200) #

  • Fixes for SDK 0.5.11.1

0.21.0+2 2013-04-29 (SDK 0.5.1.0 r22072) #

bot_io #

  • Another oops in AnsiColor
  • Un-deprecated DirectoryPopulater and MapDirecotryPopulater
    • EntityPopulator isn't there yet...

0.21.0+1 2013-04-29 (SDK 0.5.1.0 r22072) #

bot_io #

  • Oops in AnsiColor

0.21.0 2013-04-29 (SDK 0.5.1.0 r22072) #

bot_io #

  • BREAKING TempDir.dispose is now async -- returns a Future
  • DEPRECATED DirectoryPopulater and MapDirecotryPopulater
  • NEW! EntityPopulater

0.20.2 2013-04-20 (SDK 0.4.7+5 r21658) #

bot_io #

  • NEW! fileContentsMatch
  • NEW! fileSha1Hex

0.20.1 2013-04-19 (SDK 0.4.7+5 r21658) #

  • TODO...

0.20.0 2013-04-17 (SDK 0.4.7+3 r21604) #

  • The grand split from BOT begins.
  • See the BOT Changelog for work leading up to the split.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  git: ^0.1.0-dev

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:git/git.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
74
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
37
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0