get_it 7.1.3
get_it: ^7.1.3 copied to clipboard

Simple direct Service Locator that allows to decouple the interface from a concrete implementation and to access the concrete implementation from everywhere in your App"

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add get_it

With Flutter:

 $ flutter pub add get_it

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  get_it: ^7.1.3

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:get_it/get_it.dart';
1188
likes
130
pub points
99%
popularity

Publisher

fluttercommunity.dev

Simple direct Service Locator that allows to decouple the interface from a concrete implementation and to access the concrete implementation from everywhere in your App"

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

async, collection

More

Packages that depend on get_it