geometry_kp 0.0.1

  • Readme
  • Changelog
  • Installing
  • 32

geometry #

library that implement some geometry elements like points, lines, circles, etc. used as utility library.

for example:

Point pointA = Point(3.0, 5.0); Point pointB = Point(4.0, 8.0);

Line line = Line.fromPoints(pointA: pointA, pointB: pointB);

Circle circle = Circle(center: pointA, radius: 10.0);

List intersections = line.intersect(circle);

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  geometry_kp: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:geometry_kp/geometry.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
43
Health:
Code health derived from static analysis. [more]
1
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
52
Overall:
Weighted score of the above. [more]
32
Learn more about scoring.

We analyzed this package on Dec 10, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.1+4

Health issues and suggestions

Fix lib/src/circle.dart. (-92.49 points)

Analysis of lib/src/circle.dart failed with 9 errors, including:

line 4 col 8: Target of URI doesn't exist: 'package:meta/meta.dart'.

line 31 col 17: Undefined name 'required' used as an annotation.

line 31 col 40: Undefined name 'required' used as an annotation.

line 36 col 8: Undefined name 'required' used as an annotation.

line 36 col 28: Undefined name 'required' used as an annotation.

Fix lib/src/line.dart. (-76.27 points)

Analysis of lib/src/line.dart failed with 5 errors:

line 4 col 8: Target of URI doesn't exist: 'package:meta/meta.dart'.

line 13 col 15: Undefined name 'required' used as an annotation.

line 13 col 33: Undefined name 'required' used as an annotation.

line 17 col 28: Undefined name 'required' used as an annotation.

line 17 col 52: Undefined name 'required' used as an annotation.

Fix lib/src/rectangle.dart. (-57.81 points)

Analysis of lib/src/rectangle.dart failed with 3 errors:

line 3 col 8: Target of URI doesn't exist: 'package:meta/meta.dart'.

line 11 col 20: Undefined name 'required' used as an annotation.

line 11 col 46: Undefined name 'required' used as an annotation.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Low code quality prevents platform classification.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and geometry_kp.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
Dev dependencies
pedantic ^1.0.0
test ^1.0.0