geoip 1.0.1

geoIP #

A wrapper of ip-thingy.com for geolocation via IP addresses in Dart #

By: Evan Pratten

How to use #

import 'package:geoip/geoip.dart' as geoip;

main() async {
  var Data = await geoip.GetData("1.1.1.1");

  print(geoip.latlong(Data)[0]); // Print latitude

  print(geoip.latlong(Data)[1]); // Print longitude

  print(geoip.ipnumber(Data)); // Print ip address number

  print(geoip.protoversion(Data)); //Print internet protocall version

  print(geoip.region(Data)); // Print  region

  print(geoip.countrycode(Data)); // Print countrycode

  print(geoip.country(Data)); // Print country

  print(geoip.city(Data)); // Print city

  print(geoip.timezone(Data)); // Print timezone (+10:00)

  print(geoip.zipcode(Data)); // Print zipcode
}

example/example.dart

import 'package:geoip/geoip.dart' as geoip;

main() async {
  var Data = await geoip.GetData("1.1.1.1");

  print(geoip.latlong(Data)[0]); // Print latitude

  print(geoip.latlong(Data)[1]); // Print longitude

  print(geoip.ipnumber(Data)); // Print ip address number

  print(geoip.protoversion(Data)); //Print internet protocall version

  print(geoip.region(Data)); // Print  region

  print(geoip.countrycode(Data)); // Print countrycode

  print(geoip.country(Data)); // Print country

  print(geoip.city(Data)); // Print city

  print(geoip.timezone(Data)); // Print timezone (+10:00)

  print(geoip.zipcode(Data)); // Print zipcode
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  geoip: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:geoip/geoip.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Admin