geohash 0.2.1

geohash #

Build Status Coverage Status

A library for geohashing. This is used by elasticsearch and others for geo-queries.

Usage #

A simple usage example:

import 'package:geohash/geohash.dart';

main() {
  var encoded = Geohash.encode(40,-120);
  var latLng = Geohash.decode(encoded);
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.2.1 #

  • Some fixes for use in javascript.

0.2.0 #

  • Supports Dart >= 2.0

0.0.1 #

  • Initial version, created by Stagehand

example/geohash.dart

// Copyright (c) 2015, <your name>. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

library geohash.example;

import 'package:geohash/geohash.dart';

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  geohash: ^0.2.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:geohash/geohash.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
84
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
77
Overall:
Weighted score of the above. [more]
87
Learn more about scoring.

We analyzed this package on Sep 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:geohash/geohash.dart.

Health suggestions

Fix lib/src/geohash_base.dart. (-0.50 points)

Analysis of lib/src/geohash_base.dart reported 1 hint:

line 82 col 28: Use = to separate a named parameter from its default value.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is getting outdated. (-3.29 points)

The package was last published 53 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.69.5 <3.0.0
Dev dependencies
test ^1.2.0