geoairnmapdb 0.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • new64

geoairnmapdb #

Getting Started #

Geoairnmapdb Server flutter plugin, a cloud-hosted NoSQL server with realtime data synchronization through Android and iOS devices, and offline access.

Issues and feedback #

Please file geoairnmapdb specific issues, bugs, or feature requests in our issue tracker. To contribute a change to this plugin, please review our contribution guide, and send a pull request.

About us #

Airnmap is a simple, fast geolocation, love-devolving API. See our pricing plans which are customizable. Get the map design tools to create interactive, custom maps that suit your needs. Splendid visualizations. Multiplatform. Friendly Creator. Easy to customise.

0.0.4 #

  • TODO: Describe initial release.

Not working with ios 10 fixed

example/lib/main.dart

import 'dart:convert';
import 'package:flutter/material.dart';
import 'dart:async';
import 'package:flutter/services.dart';
import 'package:geoairnmapdb/geoairnmapdb.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';
  final api = GeodbApi('x', '+');
  var logLocation,fetchLocation;
  @override
  void initState() {
    super.initState();
    initPlatformState();
  }

  Future<void> initPlatformState() async {
    Map form = {
      "cid": "xxx",
      "uid": "xx",
      "sess": "xx",
      "uid_long": "xx",
      "uid_lat": "xx",
      "uid_mil": "x",
      "uid_address": "Unnamed Address",

    };

    logLocation = await api.PushSubscription(form: form);
    fetchLocation =
    await api.ReadSubscriptionLocation("xxx", "xxx");


  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Airnmap Geo'),
        ),
        body: Center(
          child: Text(fetchLocation['uid_long'].toString()),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  geoairnmapdb: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:geoairnmapdb/geoairnmapdb.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
38
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
64
Learn more about scoring.

We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Fix lib/source/geoairnmapdb_baseapi.dart. (-3.45 points)

Analysis of lib/source/geoairnmapdb_baseapi.dart reported 7 hints, including:

line 8 col 10: Name non-constant identifiers using lowerCamelCase.

line 43 col 9: Name non-constant identifiers using lowerCamelCase.

line 47 col 9: Name non-constant identifiers using lowerCamelCase.

line 51 col 9: Name non-constant identifiers using lowerCamelCase.

line 57 col 10: Name non-constant identifiers using lowerCamelCase.

Fix lib/source/geoairnmapdb_tracking.dart. (-2.96 points)

Analysis of lib/source/geoairnmapdb_tracking.dart reported 6 hints, including:

line 17 col 16: Name non-constant identifiers using lowerCamelCase.

line 48 col 14: Name non-constant identifiers using lowerCamelCase.

line 71 col 25: Set literals weren't supported until version 2.2, but this code is required to be able to run on earlier versions.

line 75 col 25: Set literals weren't supported until version 2.2, but this code is required to be able to run on earlier versions.

line 191 col 51: Avoid using braces in interpolation when not needed.

Fix lib/source/geoairnmapdb_api.dart. (-1.99 points)

Analysis of lib/source/geoairnmapdb_api.dart reported 4 hints:

line 8 col 17: Name non-constant identifiers using lowerCamelCase.

line 14 col 19: Name non-constant identifiers using lowerCamelCase.

line 29 col 32: Name non-constant identifiers using lowerCamelCase.

line 45 col 19: Name non-constant identifiers using lowerCamelCase.

Fix lib/source/geoairnmapdb_loc.dart. (-1.99 points)

Analysis of lib/source/geoairnmapdb_loc.dart reported 4 hints:

line 25 col 16: Name non-constant identifiers using lowerCamelCase.

line 28 col 16: Name non-constant identifiers using lowerCamelCase.

line 31 col 16: Name non-constant identifiers using lowerCamelCase.

line 34 col 16: Name non-constant identifiers using lowerCamelCase.

Format lib/geoairnmapdb.dart.

Run flutter format to format lib/geoairnmapdb.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
convert ^2.1.1 2.1.1
flutter 0.0.0
http ^0.12.0+4 0.12.0+4
meta ^1.1.7 1.1.8
uuid ^2.0.4 2.0.4
Transitive dependencies
async 2.4.1
charcode 1.1.3
collection 1.14.11 1.14.12
crypto 2.1.4
http_parser 3.1.4
path 1.6.4
pedantic 1.9.0
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test