generated_locator 1.1.0

  • Readme
  • Changelog
  • Installing
  • 48

Generated Locator #

A helper generator creates index files for generators, in order to generate file in another folder.

Usage #

  1. add these code to generate your dedicated generated folder. you can ignore this, if you don't need extra folder.
builders:
  ANY_UNIQUE_NAME_YOU_WANT:
    import: 'package:generated_locator/src/builder.dart'
    builder_factories: ['extraLocatorBuilder']
    build_extensions: { 'pubspec.yaml': ['YOUR_PACKAGE_NAME.extra_locator'] }
    auto_apply: root_package
    build_to: cache
    defaults:
      generate_for:
        include:
          - pubspec.yaml
        exclude:
          - lib/**
      options:
        extra_locator_name: YOUR_PACKAGE_NAME
  1. use generated.locator as reference to generate you code. or use YOUR_PACKAGE_NAME.locator as reference.

1.1.0 #

  • Add ExtractLocatorBuilder
  • Improve the way to use this package

1.0.0 #

  • First Version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  generated_locator: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Jul 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15

Analysis suggestions

Package not compatible with runtime flutter-web on Web

Because:

  • package:generated_locator/src/builder.dart that imports:
  • package:generated_locator/src/locator_builder.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io

Package not compatible with runtime js

Because:

  • package:generated_locator/src/builder.dart that imports:
  • package:generated_locator/src/locator_builder.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io

Health suggestions

Format lib/src/locator_builder.dart.

Run dartfmt to format lib/src/locator_builder.dart.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

exitCode: 255 stdout: Documenting generated_locator... Initialized dartdoc with 37 libraries in 45.9 seconds Validating docs... no issues found Documented 0 public libraries in 9.7 seconds stderr: Unhandled exception: dartdoc could not find any libraries to document #0 Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:218:9)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.4.0 <3.0.0
build ^1.2.2 1.3.0
glob ^1.2.0 1.2.0
Transitive dependencies
_fe_analyzer_shared 5.0.0
analyzer 0.39.13
args 1.6.0
async 2.4.2
charcode 1.1.3
collection 1.14.13 1.15.0-nullsafety
convert 2.1.1
crypto 2.1.5
csslib 0.16.1
html 0.14.0+3
js 0.6.2
logging 0.11.4
meta 1.2.2 1.3.0-nullsafety
node_interop 1.1.1
node_io 1.1.1
package_config 1.9.3
path 1.7.0
pub_semver 1.4.4
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0 1.3.0-nullsafety
watcher 0.9.7+15
yaml 2.2.1
Dev dependencies
build_runner ^1.7.1
pedantic ^1.7.0 1.9.2
test ^1.6.0