geetest_plugin 0.2.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 49

pub package Build Status

geetest_plugin #

Geetest Flutter plugin.

Screenshot #

Screenshot

Getting Started #

Basic function version, waiting for iteration.

Use this package as a library #

1. Depend on it #

Add this to your package's pubspec.yaml file:

dependencies:
  geetest_plugin: ^0.2.1

2. Install it #

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it #

Now in your Dart code, you can use:

import 'package:geetest_plugin/geetest_plugin.dart';

USAGE #

  Future<void> getGeetest() async {
    String result;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      result = await GeetestPlugin.getGeetest('url: api1');
    } on PlatformException {
//      _json = 'Failed to get platform version.';
    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _json = result;
    });
  }

FAQ: #

  1. [!] The 'Pods-Runner' target has transitive dependencies that include static binaries:

commenting out use_frameworks

0.2.1 #

  • update README

0.2.0 #

  • fix ios geetest lib version

0.1.8 #

  • fix ios geetest lib version

0.1.7 #

  • update flutter 1.5.4

0.1.6 #

  • fix flutter 1.0

0.1.5 #

  • fix ios geetest lib version

0.1.4 #

  • fix geetest https

0.1.3 #

  • fix ios geetest libs

0.1.2 #

  • fix ios geetest libs

0.1.1 #

  • update doc

0.1.0 #

  • update ios podspec

0.0.8 #

  • update readme

0.0.6 #

  • fixed iOS GT3Captcha pod

0.0.5 #

  • fixed android geetest libs

0.0.2 #

  • fixed android libs

0.0.1 #

  • base api.

example/README.md

geetest_plugin_example #

Demonstrates how to use the geetest_plugin plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  geetest_plugin: ^0.2.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:geetest_plugin/geetest_plugin.dart';
  
Version Uploaded Documentation Archive
0.2.1 May 30, 2019 Go to the documentation of geetest_plugin 0.2.1 Download geetest_plugin 0.2.1 archive
0.2.0 May 30, 2019 Go to the documentation of geetest_plugin 0.2.0 Download geetest_plugin 0.2.0 archive
0.1.8 May 29, 2019 Go to the documentation of geetest_plugin 0.1.8 Download geetest_plugin 0.1.8 archive
0.1.7 May 29, 2019 Go to the documentation of geetest_plugin 0.1.7 Download geetest_plugin 0.1.7 archive
0.1.6 Dec 7, 2018 Go to the documentation of geetest_plugin 0.1.6 Download geetest_plugin 0.1.6 archive
0.1.5 Nov 6, 2018 Go to the documentation of geetest_plugin 0.1.5 Download geetest_plugin 0.1.5 archive
0.1.4 Nov 6, 2018 Go to the documentation of geetest_plugin 0.1.4 Download geetest_plugin 0.1.4 archive
0.1.3 Oct 22, 2018 Go to the documentation of geetest_plugin 0.1.3 Download geetest_plugin 0.1.3 archive
0.1.2 Oct 22, 2018 Go to the documentation of geetest_plugin 0.1.2 Download geetest_plugin 0.1.2 archive
0.1.1 Sep 21, 2018 Go to the documentation of geetest_plugin 0.1.1 Download geetest_plugin 0.1.1 archive

All 16 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
95
Overall:
Weighted score of the above. [more]
49
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/generated/i18n.dart.

Run flutter format to format lib/generated/i18n.dart.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test