gapless_audio_loop 0.0.1

Gapless Audio Loop #

A flutter plugin to enable gapless loops on Android and iOs.

Android may stills see some gaps on older versions like Android 6, newer versions of the SO seems to work fine.

The Android solution is heavily inspired by this article.

At the moment this package is very simple and does not feature many media player functions, the focus on this package is to have a gapless loop, if you have suggestions to improve this package, please file an issue or send a PR.

If you need a more full-featured audio player, I suggest that you take a look on the audioplayers package.

Usage #

Drop it on your pubspec.yaml

gapless_audio_loop: ^0.0.1

Import it:

import 'package:gapless_audio_loop/gapless_audio_loop.dart';

Loading and starting the loop:

final player = GaplessAudioLoop();
await player.load('Loop-Menu.wav');

await player.play();

To stop the loop just call await player.stop()

Troubleshooting #

These are some know reasons for audio files not looping perfect:

  • Android 6 does not seems to loop perfectly the files for some reason.
  • MP3 usually have gaps due to its compress format, for more info check this question on stackexchange.
  • OGG files working only on Android: Unfortunately OGG is not support by iOs.

0.0.1 #

  • Initial release

example/README.md

gapless_audio_loop_example #

Demonstrates how to use the gapless_audio_loop plugin.

Audio file from: https://opengameart.org/content/menu-loop

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  gapless_audio_loop: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:gapless_audio_loop/gapless_audio_loop.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
48
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
68
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
path_provider ^1.1.2 1.2.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test