gallerytrigger 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 53

Flutter plugin: gallerytrigger #

A Flutter plugin able to trigger the iOS and Android galleries in order to let them update and show a new resource.

Why #

When you download a picture or video file with your Flutter app you won't see it in the gallery until your device refreshes the internal database. With this plugin you can manually trigger it and add the picture in MediaStore on Android or in Photos in iOS.

Use #

  String path = await downloadPicFromNetwork();
  String album = "Example";
  await GalleryTrigger.addResourceInGallery(filePath: path, albumName: album);

Possible Improvements #

  • Clean the procject (remove all the useless files and folders)
  • Return a consistent bool value dipending on the procedure success/failure
  • Merge the photo and video logics in swift
  • Add resources on iOS without declaring an album name

1.0.1 #

  • Fixed Context error

1.0.0+2 #

  • Added Example

1.0.0+1 #

  • Renaming

1.0.0 #

  • Add a resource file with file path to the native systems galleries (on iOS is Photos, on Android is MediaStore).

example/main.dart

import '../lib/gallerytrigger.dart';

main() async {
  String path = await downloadPicFromNetwork();
  String album = "Example";
  GalleryTrigger.addResourceInGallery(filePath: path, albumName: null);
}

downloadPicFromNetwork() {
  // This is an example
  return "foo.jpg";
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  gallerytrigger: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:gallerytrigger/gallerytrigger.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
10
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:gallerytrigger/gallerytrigger.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:gallerytrigger/gallerytrigger.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:gallerytrigger/gallerytrigger.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:gallerytrigger/gallerytrigger.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [gallerytrigger] that is in a package requiring null.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (mime_type).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
mime_type ^0.2.7 0.2.7 0.3.2
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test