galleryimage 1.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • new50

Gallery Image plugin for Flutter #

A Flutter plugin that list of images from URLs

Gallery Image

Flutter plugin that allows you to display multi image on iOS and Android.

Build

InstallationRelatedLicense

Gallery Image

Key Features #

  • Pick images from Url
  • Photos sorted
  • zoomable image

Installation #

Add galleryimage as a dependency in your pubspec.yaml file .

Import Photo View:

import 'package:galleryimage/galleryimage.dart';

Usage #

Listing URLs Images

List<String> listOfUrls= [
    "https://cosmosmagazine.com/wp-content/uploads/2020/02/191010_nature.jpg",
    "https://scx2.b-cdn.net/gfx/news/hires/2019/2-nature.jpg",
    "https://isha.sadhguru.org/blog/wp-content/uploads/2016/05/natures-temples.jpg",
    "https://upload.wikimedia.org/wikipedia/commons/7/77/Big_Nature_%28155420955%29.jpeg",
    "https://s23574.pcdn.co/wp-content/uploads/Singular-1140x703.jpg",
    "https://www.expatica.com/app/uploads/sites/9/2017/06/Lake-Oeschinen-1200x675.jpg",
    ];

To Displaying Images

@override
Widget build(BuildContext context) {
  return Container(
    child: GalleryImage(
     imageUrls: listOfUrls,,
    )
  );
}

Emailware #

Gallery Image is an emailware. Meaning, if you liked using this plugin or has helped you in anyway, I'd like you send me an email on BeshoyMelika@gmail.com about anything you'd want to say about this software. I'd really appreciate it!

photo_view - A simple zoomable image/content widget for Flutter. cached_network_image - To Load and cache network images..

You can build a gallery Images easily with this package.

See the example for more details.

License #

MIT

[0.0.1] - 0.0.1 #

  • the first version from my package

[0.0.2] - 0.0.2 #

  • update example and class

[1.0.0] - 1.0.0 #

  • Released preview version for Gallery Image

[1.0.1] - 1.0.1 #

  • fixed

[1.0.2] - 1.0.2 #

  • fixed

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:galleryimage/galleryimage.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      debugShowCheckedModeBanner: false,
      title: 'Gallery Image Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
        visualDensity: VisualDensity.adaptivePlatformDensity,
      ),
      home: MyHomePage(title: 'Gallery Image Demo'),
    );
  }
}

class MyHomePage extends StatelessWidget {
  final title;

  const MyHomePage({Key key, this.title}) : super(key: key);
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(title),
      ),
      body: Center(
        child: Column(
          mainAxisAlignment: MainAxisAlignment.center,
          children: <Widget>[
            Text("Tap to show image"),
            GalleryImage(
              imageUrls: [
                "https://cosmosmagazine.com/wp-content/uploads/2020/02/191010_nature.jpg",
                "https://scx2.b-cdn.net/gfx/news/hires/2019/2-nature.jpg",
                "https://isha.sadhguru.org/blog/wp-content/uploads/2016/05/natures-temples.jpg",
                "https://upload.wikimedia.org/wikipedia/commons/7/77/Big_Nature_%28155420955%29.jpeg",
                "https://s23574.pcdn.co/wp-content/uploads/Singular-1140x703.jpg",
                "https://www.expatica.com/app/uploads/sites/9/2017/06/Lake-Oeschinen-1200x675.jpg"
              ],
            ),
          ],
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  galleryimage: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:galleryimage/galleryimage.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform android

Because of import path [package:galleryimage/galleryimage.dart, package:galleryimage/gallery_image_view_wrapper.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/cache_manager.dart, package:path_provider/path_provider.dart, package:path_provider_linux/path_provider_linux.dart] that declares support for platforms: linux

Package does not support Flutter platform ios

Because of import path [package:galleryimage/galleryimage.dart, package:galleryimage/gallery_image_view_wrapper.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/cache_manager.dart, package:path_provider/path_provider.dart, package:path_provider_linux/path_provider_linux.dart] that declares support for platforms: linux

Package does not support Flutter platform linux

Because of import path [package:galleryimage/galleryimage.dart, package:galleryimage/gallery_image_view_wrapper.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/web/web_helper.dart, package:flutter_cache_manager/src/cache_store.dart, package:sqflite/sqflite.dart] that declares support for platforms: android, ios, macos

Package does not support Flutter platform macos

Because of import path [package:galleryimage/galleryimage.dart, package:galleryimage/gallery_image_view_wrapper.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/cache_manager.dart, package:path_provider/path_provider.dart, package:path_provider_linux/path_provider_linux.dart] that declares support for platforms: linux

Package does not support Flutter platform web

Because of import path [package:galleryimage/galleryimage.dart, package:galleryimage/gallery_image_view_wrapper.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_web.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/web/web_helper.dart, package:flutter_cache_manager/src/cache_store.dart, package:sqflite/sqflite.dart] that declares support for platforms: android, ios, macos

Package does not support Flutter platform windows

Because of import path [package:galleryimage/galleryimage.dart, package:galleryimage/gallery_image_view_wrapper.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/web/web_helper.dart, package:flutter_cache_manager/src/cache_store.dart, package:sqflite/sqflite.dart] that declares support for platforms: android, ios, macos

Package not compatible with SDK dart

because of import path [galleryimage] that is in a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
cached_network_image ^2.2.0+1 2.2.0+1 2.3.0-rc
flutter 0.0.0
photo_view ^0.9.2 0.9.2
Transitive dependencies
charcode 1.1.3
clock 1.0.1
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
file 5.2.1
flutter_cache_manager 1.4.1
http 0.12.1
http_parser 3.1.4
intl 0.16.1
meta 1.1.8
path 1.7.0
path_provider 1.6.11
path_provider_linux 0.0.1+2
path_provider_macos 0.0.4+3
path_provider_platform_interface 1.0.2
pedantic 1.9.0 1.9.1
platform 2.2.1
plugin_platform_interface 1.0.2
process 3.0.13
rxdart 0.24.1
sky_engine 0.0.99
source_span 1.7.0
sqflite 1.3.1
sqflite_common 1.0.2+1
string_scanner 1.0.5
synchronized 2.2.0+1
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
uuid 2.2.0
vector_math 2.0.8
xdg_directories 0.1.0
Dev dependencies
flutter_test