g_simple_calendar 0.0.1

  • Readme
  • Changelog
  • Installing
  • new48

g_simple_calendar #

Simple Calendar Widget

Getting Started #

For help getting started with Flutter, view our online documentation.

Props #

propstypesdefaultValues
dateDateTime
selectedColorColorColors.grey
celdTextColorColorColors.black
titleStyleTextStyleTextStyle(color: widget.celdTextColor ?? Colors.black, fontSize: 18)
celTextEmptyStringX
onRangeSelectedFunction(List

Install #

Add g_simple_calendar as a dependency in pubspec.yaml For help on adding as a dependency, view the documentation.

Usage #

Widget build(BuildContext context) {
    
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: GSimpleCalendar(
        date: DateTime.now(),
      ),
    );
  }

[0.0.1] - TODO: Add release date. #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  g_simple_calendar: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:g_simple_calendar/g_simple_calendar.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
12
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • g_simple_calendar that is a package requiring null.

Health suggestions

Format lib/g_simple_calendar.dart.

Run flutter format to format lib/g_simple_calendar.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and g_simple_calendar.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
intl ^0.16.1 0.16.1
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
path 1.7.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test