fx 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 56

fx #

A library of fx widgets for Flutter.

Wavy #

Adds a 'wavy' effect to any widget along the horizontal plane.

  child: Text('Wavy Text!'),

[0.0.1] - TODO: Add release date. #

  • Adds Wavy fx widget


// Copyright 2018 The Chromium Authors. All rights reserved.
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.

import 'package:flutter/material.dart';
import 'package:fx/fx.dart';

void main() => runApp(FxApp());

class FxApp extends StatelessWidget {
  Widget build(BuildContext context) {
    return MaterialApp(
      home: FxPage(),

class FxPage extends StatelessWidget {
  Widget build(BuildContext context) {
    return Scaffold(body: SafeArea(child: FxDemos()));

class FxDemos extends StatelessWidget {
  Widget build(BuildContext context) {
    return Column(
      mainAxisAlignment: MainAxisAlignment.center,
      children: [WavyDemo()],

class WavyDemo extends StatelessWidget {
  Widget build(BuildContext context) {
    return Wavy(
      duration: Duration(milliseconds: 750),
      child: Row(
        mainAxisAlignment: MainAxisAlignment.center,
        children: [
          SizedBox(width: 20.0),

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  fx: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:fx/fx.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Maintenance suggestions

Package is getting outdated. (-50.14 points)

The package was last published 78 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies