fule_scaffold 0.1.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 54

FuleScaffold #

Pub Version GitHub

一个可以调整状态栏文字和背景颜色的组件。

注意:使用该组件会与AppBar设置冲突导致失效,通常用于无AppBar界面。

该项目还在探索阶段,对外接口可能会存在较大变化,请选择好使用的版本。

开始 #

安装 #

在pubspec.yaml中添加依赖包

fule_scaffold: '^0.1.1'

获取依赖包

$ flutter pub get

引入 #

import 'package:fule_scaffold/fule_scaffold.dart';

参数 #

属性类型默认值必填说明组件版本
statusBarStyleStatusBarStyleStatusBarStyle.black状态栏样式0.1.0
statusBarColorColorColors.transparent状态栏颜色0.1.0
useSafeAreabooltrue是否使用安全区域0.1.0
backgroundColorColor-背景颜色0.1.0
bodyWidget-子组件0.1.0

说明 #

  1. StatusBarStyle 为枚举类型,分别为 StatusBarStyle.black 和 StatusBarStyle.white 。

[0.1.1] 2020-05-11 #

  • 修复导致部分内置组件显示错位的问题

[0.1.0] 2020-05-08 #

  • FuleScaffold第一个版本 🎉

[0.1.1] 2020-05-11 #

  • Fixed an issue that caused some of the built-in components to be misplaced

[0.1.0] 2020-05-08 #

  • First version of FuleScaffold 🎉

example/example.dart

import 'package:flutter/material.dart';
import 'package:fule_scaffold/fule_scaffold.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  MyApp({Key key}) : super(key: key);

  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: FuleScaffold(
        body: Container(
          child: Image.network(
            'https://i.loli.net/2020/04/16/gpIVeN8a2m93nXt.jpg',
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fule_scaffold: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fule_scaffold/fule_scaffold.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
8
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
54
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [fule_scaffold] that is in a package requiring null.

Health suggestions

Format lib/fule_scaffold.dart.

Run flutter format to format lib/fule_scaffold.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test