fson_parser 0.8.4

  • Readme
  • Changelog
  • Installing
  • 32

fson_parser #

The official FSON parser.

[0.8.4] - Hotfix #

  • fixed parser

[0.8.3] - Hotfix #

  • fixed parser

[0.8.2] - Hotfix #

  • fixed parser

[0.8.1] - Hotfix #

  • dependecies updated

[0.8.0] - First release #

  • first release (Beta)

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fson_parser: ^0.8.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fson_parser/fson_parser.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
74
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
32
Learn more about scoring.

We analyzed this package on Jul 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Health issues and suggestions

Fix lib/src/fson_core.dart. (-25 points)

Analysis of lib/src/fson_core.dart failed with 1 error:

line 2 col 8: Target of URI doesn't exist: 'package:path/path.dart'.

Document public APIs. (-1 points)

50 out of 50 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/fson_parser.dart.

Run flutter format to format lib/fson_parser.dart.

Format lib/src/fson_base.dart.

Run flutter format to format lib/src/fson_base.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/fson_models.dart (Run flutter format to format lib/src/fson_models.dart.)
  • lib/src/fson_schema.dart (Run flutter format to format lib/src/fson_schema.dart.)
  • lib/src/fson_validator.dart (Run flutter format to format lib/src/fson_validator.dart.)

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and fson_parser.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test