fresh_dio 0.2.0
fresh_dio: ^0.2.0 copied to clipboard

Dart native js
Flutter Android iOS web

An http interceptor for token refresh. Fresh is built on top of package:dio and manages authentication tokens transparently.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  fresh_dio: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:fresh_dio/fresh_dio.dart';
14
likes
110
pub points
87%
popularity

An http interceptor for token refresh. Fresh is built on top of package:dio and manages authentication tokens transparently.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

felangelov@gmail.com

License

MIT (LICENSE)

Dependencies

dio, fresh, meta

More

Packages that depend on fresh_dio