freelancer_sdk 0.0.1+3

  • Readme
  • Changelog
  • Example
  • Installing
  • 44

Freelancer.com Flutter SDK #

Unofficial Freelancer.com SDK for your Flutter applications.

NOTE: This is still in technical preview

Freelancer API #

Use the Freelancer API to access a cloud workforce of skilled freelancers from your website, app or software. https://developers.freelancer.com/

Features #

  • Freelancer Payload API Models
  • Easy way of accessing Freelancer.com Developer API

Roadmap #

  • To be the official SDK of Freelancer.com Developer API for Flutter
  • Provide a built-in Freelancer HTTP Client
  • TBD

Contributing #

  1. Fork it (https://github.com/joshuadeguzman/freelancer-sdk-flutter/fork)
  2. Create your feature branch (git checkout -b feature/fooBar)
  3. Commit your changes (git commit -am 'Add some fooBar')
  4. Push to the branch (git push origin feature/fooBar)
  5. Create a new Pull Request

License #

Freelancer.com Flutter SDK is released under the GNU General Public License v3.0. See LICENSE for details.

[0.0.1+3] - December 30, 2019

  • Add initial sample app setup
  • Update dependencies and SDK version

[0.0.1+2] - September 23, 2019

  • Add FLResponse, and FLProjectResult for serializing parent payload of projects list.

[0.0.1+1] - September 23, 2019

  • Update technical preview release version.

  • Add more unit tests for the Project Data Models.

[0.0.1] - September 23, 2019

  • Freelancer Project Data Models (Includes BidStats, Country, Budget, Currency, Location, Upgrades)

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  freelancer_sdk: ^0.0.1+3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:freelancer_sdk/models/fl_bid_stat.dart';
import 'package:freelancer_sdk/models/fl_budget.dart';
import 'package:freelancer_sdk/models/fl_country.dart';
import 'package:freelancer_sdk/models/fl_currency.dart';
import 'package:freelancer_sdk/models/fl_location.dart';
import 'package:freelancer_sdk/models/fl_project.dart';
import 'package:freelancer_sdk/models/fl_project_result.dart';
import 'package:freelancer_sdk/models/fl_response.dart';
import 'package:freelancer_sdk/models/fl_timezone.dart';
import 'package:freelancer_sdk/models/fl_upgrades.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Jan 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health issues and suggestions

Document public APIs. (-1 points)

237 out of 237 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/models/fl_project.dart.

Run flutter format to format lib/models/fl_project.dart.

Format lib/models/fl_timezone.dart.

Run flutter format to format lib/models/fl_timezone.dart.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test