foloosi_plugins 1.0.15 copy "foloosi_plugins: ^1.0.15" to clipboard
foloosi_plugins: ^1.0.15 copied to clipboard

A Flutter plugin for making payments via Foloosi Payment Gateway. Fully supports Android and iOS.

foloosi_plugins #

A Flutter plugin for making payments via Foloosi Payment Gateway. Fully supports Android and iOS.

Installation #

See Foloosi SDK for more info.

Dart Versions #

environment:
  sdk: ">=2.12.0 <4.0.0"

Android Requirement #

Set up Android build.gradle (android/app/build.gradle) #

android {
    defaultConfig {
        minSdkVersion 21
    }
    buildTypes {
        release {
            minifyEnabled false
            shrinkResources false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
            signingConfig signingConfigs.release
        }
    }
    dependencies {
        implementation 'com.foloosi:FoloosiSDK:2.0.24'
        implementation 'com.google.code.gson:gson:2.10.1'
    }
}

Proguard Rules (Mandatory for release build) #

-keepclassmembers class * {
    @android.webkit.JavascriptInterface <methods>;
}

-keepattributes JavascriptInterface
-keepattributes *Annotation*

-dontwarn com.foloosi.**
-keep class com.foloosi.** {*;}

-optimizations !method/inlining/*

Note #

  • 4.1.0 or higher is required for settings build.gradle
  • 1.4.30 or higher is required for kotlin version

iOS Requirement #

iOS Deployment Target 12+ (iPhone, iPad)

SDK Properties Note #

If you are using the Foloosi secret and merchant keys as a string in flutter, remember to escape the $ dollar signs although it is recommended to load these from your backend

3
likes
110
pub points
61%
popularity

Publisher

unverified uploader

A Flutter plugin for making payments via Foloosi Payment Gateway. Fully supports Android and iOS.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on foloosi_plugins