fm_gaode_map 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 40

fm_gaode_map #


Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.0.2 #

0.0.1 #

  • TODO: Describe initial release.


import 'package:flutter/material.dart';
import './page.dart';
import 'view_test.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  Widget build(BuildContext context) {
    return new MaterialApp(
      debugShowCheckedModeBanner: false,
      title: 'fm_gaode',
      theme: new ThemeData(
      home: Home(),

class Home extends StatefulWidget {
  _HomeState createState() => _HomeState();

class _HomeState extends State<Home> {
  void initState() {

  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text('高德地图测试'),
        centerTitle: true,
      body: Center(
          child: Column(
        children: <Widget>[
            child: Text("进入"),
            onPressed: () {
                new MaterialPageRoute(builder: (context) => PageTest()),
            child: Text("进入test"),
            onPressed: () {
                new MaterialPageRoute(builder: (context) => ViewText()),

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  fm_gaode_map: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:fm_gaode_map/fm_gaode_map.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health issues and suggestions

Document public APIs. (-0.41 points)

340 out of 347 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/map/over_types/base.dart. (-1 points)

Analysis of lib/map/over_types/base.dart reported 2 hints:

line 6 col 7: Avoid wrapping fields in getters and setters just to be "safe".

line 7 col 18: Avoid wrapping fields in getters and setters just to be "safe".

Format lib/extend/drawer/drtypes/base.dart.

Run flutter format to format lib/extend/drawer/drtypes/base.dart.

Format lib/fm_gaode_map.dart.

Run flutter format to format lib/fm_gaode_map.dart.

Fix additional 5 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/map/over_types/circle.dart (Run flutter format to format lib/map/over_types/circle.dart.)
  • lib/map/over_types/line.dart (Run flutter format to format lib/map/over_types/line.dart.)
  • lib/map/over_types/mark.dart (Run flutter format to format lib/map/over_types/mark.dart.)
  • lib/map/over_types/text.dart (Run flutter format to format lib/map/over_types/text.dart.)
  • lib/types.dart (Run flutter format to format lib/types.dart.)

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
fm_fit ^0.0.2 0.0.3
uuid ^2.0.2 2.0.4
Transitive dependencies
charcode 1.1.3
collection 1.14.11 1.14.12
convert 2.1.1
crypto 2.1.4
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies