flux_validator_dart 1.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • new74

Flux Validator Dart #

A package to validate strings and input data for dart.

Getting Started #

Install #

Add to your pubspec.yaml

dependencies:
  flux_validator_dart: <lastest-version>

And then run # pub get in your terminal.

How to use #

Import #

import 'package:flux_validator_dart/flux_validator_dart.dart';

Use #

Validator.email(value) // returns bool

Validator Options #

Mercosul car plate #

Ex: AAA-0000 or AAA-0A00

Validator.carPlate(value)
Brazilian CEP #

Ex: 00000-000

Validator.cep(value)
Brazilian CNH #

Ex: 00000000000

Validator.cnh(value)
Brazilian CNPJ #

Ex: 00.000.000/0000-00

Validator.cnpj(value)
Brazilian CPF #

Ex: 000.000.000-00

Validator.cpf(value)
Brazilian CPF & CNPJ

Ex: 000.000.000-00|0000-00

Validator.cpfCnpj(value)
dd/mm/yyyy Date #

Ex: 00/00/0000

Validator.date(value)
Email #

Ex: aaaaa@aaa.aaa.aa

Validator.email(value)
Numbers #

Ex: 0123456

Validator.numbers(value)
Letters #

Ex: abcdefgABCDEFG

Validator.letters(value)
Brazilian Phone #

Ex: +55 (11) 0 0000-0000

Validator.phone(value)
Brazilian Renavam #

Ex: 00000000000

Validator.renavam(value)

Changelog #

All notable changes to this project will be documented in this file.

The format is based on Keep a Changelog, and this project adheres to Semantic Versioning.

[Unreleased]

[1.0.3] - 2019-09-23

Added #

  • Tests
  • Example

Changed #

Removed #

[1.0.2] - 2019-09-23

Added #

  • Validations
  • README

Changed #

Removed #

[1.0.0] - 2019-09-23

Added #

  • Initial Package published.

Changed #

Removed #

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flux_validator_dart: ^1.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flux_validator_dart/flux_validator_dart.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
49
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Oct 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

33 out of 33 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
flutter_test