flutube 0.4.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 92

FluTube #

Embed Youtube videos in your flutter apps just by passing in the video URL!

PLEASE NOTE: Embedding copyrighted videos is actually not possible. Please use flutter_youtube instead.

This plugin uses an in-built API so the official YT API is not used here and therefore you don't need any API keys.

This plugin also uses the great plugin Chewie to provide a nice material or cupertino video player. And please note this plugin is NOT a replacement for Chewie. Chewie is a great plugin and here we are just using it.

Huge thank you to @brianegan for developing Chewie.

Demo #

Demo

Installation #

In your pubspec.yaml file within your Flutter Project:

dependencies:
  flutube: ^0.4.1

Use it #

import 'package:flutube/flutube.dart';

final flutubePlayer = Flutube(
  '<Youtube URL>',
  aspectRatio: 16 / 9,
  autoPlay: true,
  looping: true,
);

Example #

Please run the app in the example/ folder to start playing!

0.4.1 #

  • Changed dispose approach trying to fix some errors derived from video disposal

0.4.0 #

  • Added thumbnail to videos (thumbnail loads directly from YT) You can control whether you want to display the original video thumbnail with the showThumb property. The default value is true.

0.3.1 #

  • Fix bugs
  • You can now access the inner video controller via GlobalKey<FlutubeState>

0.3.0 #

  • Updated Chewie to 0.8.0
  • Removed unnecessary code
  • Fixed bugs

0.2.0 #

  • Fix #2
  • Fixed a potential bug that made videos don't stop playing when route was deactivated

0.1.2 #

  • Fixed a bug which made autoStart property not work without setting autoInitialize to true.

0.1.1 #

  • Updated http dependency to allow installation on all Flutter channels.

0.1.0 #

  • Added in-plugin API. The plugin does not depend anymore on the YT Link Deconstructor hosted on HerokuApp.

0.0.1 #

  • Initial release.

example/README.md

flutube_example #

Demonstrates how to use the flutube plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutube: ^0.4.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutube/flutube.dart';
  
Version Uploaded Documentation Archive
0.7.3 Feb 26, 2019 Go to the documentation of flutube 0.7.3 Download flutube 0.7.3 archive
0.7.2 Feb 26, 2019 Go to the documentation of flutube 0.7.2 Download flutube 0.7.2 archive
0.7.1 Jan 30, 2019 Go to the documentation of flutube 0.7.1 Download flutube 0.7.1 archive
0.7.0 Jan 26, 2019 Go to the documentation of flutube 0.7.0 Download flutube 0.7.0 archive
0.6.2 Jan 23, 2019 Go to the documentation of flutube 0.6.2 Download flutube 0.6.2 archive
0.6.1 Jan 23, 2019 Go to the documentation of flutube 0.6.1 Download flutube 0.6.1 archive
0.6.0 Jan 22, 2019 Go to the documentation of flutube 0.6.0 Download flutube 0.6.0 archive
0.5.2 Jan 22, 2019 Go to the documentation of flutube 0.5.2 Download flutube 0.5.2 archive
0.5.1 Dec 10, 2018 Go to the documentation of flutube 0.5.1 Download flutube 0.5.1 archive
0.5.0 Dec 10, 2018 Go to the documentation of flutube 0.5.0 Download flutube 0.5.0 archive

All 22 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
84
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
92
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15
  • Flutter: 1.5.8

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/flutube_player.dart. (-1 points)

Analysis of lib/src/flutube_player.dart reported 2 hints:

line 151 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 169 col 39: Avoid using braces in interpolation when not needed.

Format lib/flutube.dart.

Run flutter format to format lib/flutube.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
chewie ^0.8.0 0.8.0 0.9.7
flutter 0.0.0
http >=0.12.0 <0.13.0 0.12.0+2
open_iconic_flutter >=0.3.0 <0.4.0 0.3.0
Transitive dependencies
async 2.2.0
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.2
pedantic 1.6.0
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
video_player 0.7.2 0.10.0+8