flutube 0.2.0

FluTube #

Embed Youtube videos in your flutter apps just by passing in the video URL!

This plugin uses an in-built API so the official YT API is not used here and therefore you don't need any API keys.

This plugin also uses the great plugin Chewie to provide a nice material or cupertino video player. And please note this plugin is NOT a replacement for Chewie. Chewie is a great plugin and here we are just using it. I have updated Chewie with some of the pull requests it had on the original repo as well.

Huge thank you to @brianegan for developing Chewie.

Demo #

Demo

Installation #

In your pubspec.yaml file within your Flutter Project:

dependencies:
  flutube: ^0.2.0

Use it #

import 'package:flutube/flutube.dart';

final flutubePlayer = Flutube(
  '<Youtube URL>',
  aspectRatio: 16 / 9,
  autoPlay: true,
  looping: true,
);

Example #

Please run the app in the example/ folder to start playing!

0.2.0 #

  • Fix #2
  • Fixed a potential bug that made videos don't stop playing when route was deactivated

0.1.2 #

  • Fixed a bug which made autoStart property not work without setting autoInitialize to true.

0.1.1 #

  • Updated http dependency to allow installation on all Flutter channels.

0.1.0 #

  • Added in-plugin API. The plugin does not depend anymore on the YT Link Deconstructor hosted on HerokuApp.

0.0.1 #

  • Initial release.

example/README.md

flutube_example #

Demonstrates how to use the flutube plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutube: ^0.2.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutube/flutube.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
81
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
88
Learn more about scoring.

We analyzed this package on Jul 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/flutube_player.dart. (-0.50 points)

Analysis of lib/src/flutube_player.dart reported 1 hint:

line 117 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Format lib/flutube.dart.

Run flutter format to format lib/flutube.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (video_player).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
http >=0.11.3 <0.13.0 0.12.0+2
open_iconic_flutter >=0.3.0 <0.4.0 0.3.0
video_player >=0.7.0 <0.8.0 0.7.2 0.10.1+3
Transitive dependencies
async 2.2.0
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.2
pedantic 1.8.0+1
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8

Admin