flutuate_api 1.0.0+3

  • Readme
  • Changelog
  • Example
  • Installing
  • 56

ATTENTION: This package is no longer working, it was moved to Retrolite. Please, see there for more informations.

1.0.0+3 #

  • Put this package out of use.

1.0.0+2 #

  • Corrected link to Retrolite package.

1.0.0+1 #

  • Added http dependency.

1.0.0 #

  • First release.

0.0.1 #

  • Initial version, created by Luciano Rodrigues

example/flutuate_api_example.dart

///
/// For example, please, see the package [Retrolite](https://pub.dartlang.org/retrolite).
///
main() {}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutuate_api: ^1.0.0+3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutuate_api/flutuate_api.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
22
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Jan 25, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4

Health suggestions

Fix lib/src/Headers.dart. (-1.49 points)

Analysis of lib/src/Headers.dart reported 3 hints:

line 10 col 12: Unnecessary new keyword.

line 15 col 12: Unnecessary new keyword.

line 71 col 12: Unnecessary new keyword.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
http ^0.12.0+2 0.12.0+4
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.12
http_parser 3.1.3
meta 1.1.8
path 1.6.4
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
pedantic ^1.0.0 1.9.0
test ^1.0.0