flutterwave_standard 1.0.3 icon indicating copy to clipboard operation
flutterwave_standard: ^1.0.3 copied to clipboard

Flutterwave's official library that wraps the standard implementation.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add flutterwave_standard

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  flutterwave_standard: ^1.0.3

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:flutterwave_standard/core/TransactionCallBack.dart';
import 'package:flutterwave_standard/core/flutterwave.dart';
import 'package:flutterwave_standard/core/navigation_controller.dart';
import 'package:flutterwave_standard/core/transaction_status.dart';
import 'package:flutterwave_standard/flutterwave.dart';
import 'package:flutterwave_standard/models/TransactionError.dart';
import 'package:flutterwave_standard/models/requests/customer.dart';
import 'package:flutterwave_standard/models/requests/customizations.dart';
import 'package:flutterwave_standard/models/requests/standard_request.dart';
import 'package:flutterwave_standard/models/responses/charge_response.dart';
import 'package:flutterwave_standard/models/responses/standard_response.dart';
import 'package:flutterwave_standard/models/subaccount.dart';
import 'package:flutterwave_standard/utils.dart';
import 'package:flutterwave_standard/view/FlutterwaveWebView.dart';
import 'package:flutterwave_standard/view/flutterwave_style.dart';
import 'package:flutterwave_standard/view/payment_widget.dart';
import 'package:flutterwave_standard/view/view_utils.dart';
9
likes
110
pub points
92%
popularity

Publisher

unverified uploader

Flutterwave's official library that wraps the standard implementation.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_inappwebview, fluttertoast, http

More

Packages that depend on flutterwave_standard