flutteradform 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 65

flutter_adform #

Adform plugin for Flutter.

Installation #

  1. Dependencies Add this to your package's pubspec.yaml file:
dependencies:
  flutter_adform: "^0.0.3"
  1. You can install packages from the command line:

with Flutter:

$ flutter pub get

Setup iOS #

Add this to Info.plist

<key>LSApplicationQueriesSchemes</key>
<array>
	<string>sms</string>
	<string>tel</string>
</array>
<key>io.flutter.embedded_views_preview</key>
<true/>

Support #

Supported Platforms #

  • 0.0.1 >= iOS
  • 0.0.1 >= AndroidX

Supported Adform ads #

  • Inline Ads (SmartAdSize)

0.0.1 #

  • Implemented AdInline ad.

0.0.2 #

  • Implemented AdInline on ad load listener.

0.0.3 #

  • Fixed iOS build.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutteradform/adform_adinline.dart';
import 'package:flutteradform/adform_event.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  void initState() {
    super.initState();
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Adform plugin example api'),
        ),
        body: Center(
          child: AdformAdInline(
              masterTagId: 142493,
              width: 300,
              height: 250,
              listener: (AdformEvent event, Map<String, dynamic> args) {
                switch (event) {
                  case AdformEvent.onAdLoadSuccess:
                    print("Ad successfully loaded");
                    break;
                  case AdformEvent.onAdLoadFail:
                    print("Ad load failed ${args["error"]}");
                    break;
                  default:
                }
              }),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutteradform: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutteradform/flutteradform.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
43
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:flutteradform/flutteradform.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:flutteradform/flutteradform.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:flutteradform/flutteradform.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:flutteradform/flutteradform.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • flutteradform that is a package requiring null.

Health suggestions

Format lib/adform_event.dart.

Run flutter format to format lib/adform_event.dart.

Format lib/generated/i18n.dart.

Run flutter format to format lib/generated/i18n.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test