flutter_youtube_view 1.1.4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 84

flutter_youtube_view #

This plugin provides YoutubeView widget.

Supported

Status Develop #

  • Android: DONE
  • iOS: DONE

How to Use #

1. Depend

Add this to you package's pubspec.yaml file:

dependencies:
  flutter_youtube_view: ^1.1.0

2. Install

Run command:

$ flutter packages get

3. Import

Import in Dart code:

import 'package:flutter_youtube_view/flutter_youtube_view.dart';

4. Using Youtube View

 Container(
          child: FlutterYoutubeView(
                onViewCreated: _onYoutubeCreated,
                listener: this,
                params: YoutubeParam(
                      videoId: 'gcj2RUWQZ60', 
                      showUI: false, 
                      startSeconds: 0.0),
                )
            ),

Salient Features #

  • play()
  • pause()
  • loadOrCueVideo()
  • seekTo()
  • setVolume()
  • Player listener
  • State: UNKNOWN, UNSTARTED, ENDED, PLAYING, PAUSED, BUFFERING, VIDEO_CUED
  • Status: ready, error
  • Duration
  • CurrentTime

0.0.1 #

Init project

1.1.0 #

Fixed issue #https://github.com/hoanglm4/flutter_youtube_view/issues/2

1.1.1 #

https://github.com/hoanglm4/flutter_youtube_view/issues/5

1.1.4 #

https://github.com/hoanglm4/flutter_youtube_view/issues/1 https://github.com/hoanglm4/flutter_youtube_view/issues/8 Fixed: Android: Video play in background

example/README.md

flutter_youtube_view_example #

Demonstrates how to use the flutter_youtube_view plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_youtube_view: ^1.1.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_youtube_view/flutter_youtube_view.dart';
  
Version Uploaded Documentation Archive
1.1.4 Apr 1, 2019 Go to the documentation of flutter_youtube_view 1.1.4 Download flutter_youtube_view 1.1.4 archive
1.1.1 Mar 24, 2019 Go to the documentation of flutter_youtube_view 1.1.1 Download flutter_youtube_view 1.1.1 archive
1.1.0 Mar 16, 2019 Go to the documentation of flutter_youtube_view 1.1.0 Download flutter_youtube_view 1.1.0 archive
0.0.1 Mar 1, 2019 Go to the documentation of flutter_youtube_view 0.0.1 Download flutter_youtube_view 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
79
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
75
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-0.23 points)

37 out of 38 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flutter_youtube_view.dart.

Run flutter format to format lib/flutter_youtube_view.dart.

Format lib/src/youtube_param.dart.

Run flutter format to format lib/src/youtube_param.dart.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8