flutter_walle 0.0.2

  • README.md
  • Example
  • Installing
  • Versions
  • 47

flutter_walle #

Get channel information (by meituan walle) from within the Flutter application.

Usage #


import 'package:flutter_walle/flutter_walle.dart';

String channel = 'Unknown';
try {
    channel = await FlutterWalle.channel;
} catch (e) {

0.0.2 #

  • Add some description to find easy.

0.0.1 #

  • Implements meituan walle read channel.


flutter_walle_example #

Demonstrates how to use the flutter_walle plugin.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_walle: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_walle/flutter_walle.dart';
Version Uploaded Documentation Archive
0.0.2 Mar 4, 2019 Go to the documentation of flutter_walle 0.0.2 Download flutter_walle 0.0.2 archive
0.0.1 Mar 4, 2019 Go to the documentation of flutter_walle 0.0.1 Download flutter_walle 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jun 26, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

4 out of 4 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flutter_walle.dart.

Run flutter format to format lib/flutter_walle.dart.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies