flutter_video_player 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 56

flutter_video_player #

A Flutter plugin for integrating qiniu video player in iOS and Android applications.

During development, please do not use it in production environment. #

Support platform #

  • Android ✓
  • iOS 𐄂

0.0.1 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutter_video_player/flutter_video_player.dart';

void main() => runApp(MyApp());

//const String videoPath = 'rtmp://live.hkstv.hk.lxdns.com/live/hks1';
const String videoPath =
    'http://qn.isanye.cn/%E5%A5%87%E8%BF%B9%E7%9A%84%E5%B1%B1.mp4';

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  VideoController _controller;
  double _aspectRatio = 4 / 3;

  _onVideoCreated(VideoController controller) {
    setState(() {
      _controller = controller;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Flutter video player example'),
        ),
        body: Center(
          child: AspectRatio(
            aspectRatio: _aspectRatio,
            child: FlutterVideoPlayer(
              options: PlayerOptions(
                videoPath: videoPath,
              ),
              onVideoCreated: _onVideoCreated,
              onPrepare: () {
                _controller.start();
              },
              onVideoSizeChanged: (int width, int height) {
                setState(() {
                  _aspectRatio = width / height;
                });
              },
            ),
          ),
        ),
        persistentFooterButtons: <Widget>[
          FlatButton(
            child: Text('START'),
            onPressed: () {
              _controller.start();
              _controller.getMetaData();
            },
          ),
          FlatButton(
            child: Text('PAUSE'),
            onPressed: () {
              _controller.pause();
            },
          ),
        ],
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_video_player: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_video_player/flutter_video_player.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
39
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
33
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1
  • Flutter: 1.17.3

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:flutter_video_player/flutter_video_player.dart]

Package does not support Flutter platform macos

Because of import path [package:flutter_video_player/flutter_video_player.dart]

Package does not support Flutter platform web

Because of import path [package:flutter_video_player/flutter_video_player.dart]

Package does not support Flutter platform windows

Because of import path [package:flutter_video_player/flutter_video_player.dart]

Package not compatible with SDK dart

because of import path [flutter_video_player]

Health suggestions

Fix lib/src/video_controller.dart. (-0.50 points)

Analysis of lib/src/video_controller.dart reported 1 hint:

line 38 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Maintenance suggestions

Package is getting outdated. (-57.26 points)

The package was last published 82 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8