flutter_vant_kit 0.2.3

  • Readme
  • Changelog
  • Example
  • Installing
  • new68

Flutter Vant Kit #

Flutter Vant Kit is a Vant style flutter UI library.

Introduction #

How to use #

dependencies:
  flutter_vant_kit: ^0.2.2

How to run demo #

cd example/
flutter run

API #

View Documentation 或 【中文版|English

Demo Screenshot #

Buttons Cell Field PasswordInput ImageWall Steps TreeSelect AddressList

CHANGELOG #

0.2.3 #

  • Chore list;
  • Update docs;

0.2.0 #

  • Add calendar and picker;
  • Fix some components bugs;

0.1.7 #

  • Organize documents;
  • Adjust code structure;

0.1.0 #

  • Initial version;
  • Update README;

example/README.md

Flutter Vant Kit Example #

flutter run

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_vant_kit: ^0.2.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_vant_kit/main.dart';
import 'package:flutter_vant_kit/theme/style.dart';
import 'package:flutter_vant_kit/widgets/actionSheet.dart';
import 'package:flutter_vant_kit/widgets/addressEdit.dart';
import 'package:flutter_vant_kit/widgets/addressList.dart';
import 'package:flutter_vant_kit/widgets/avatar.dart';
import 'package:flutter_vant_kit/widgets/badge.dart';
import 'package:flutter_vant_kit/widgets/button.dart';
import 'package:flutter_vant_kit/widgets/calendar.dart';
import 'package:flutter_vant_kit/widgets/card.dart';
import 'package:flutter_vant_kit/widgets/cell.dart';
import 'package:flutter_vant_kit/widgets/cellGroup.dart';
import 'package:flutter_vant_kit/widgets/checkbox.dart';
import 'package:flutter_vant_kit/widgets/checkboxGroup.dart';
import 'package:flutter_vant_kit/widgets/collapse.dart';
import 'package:flutter_vant_kit/widgets/collapseItem.dart';
import 'package:flutter_vant_kit/widgets/coupon.dart';
import 'package:flutter_vant_kit/widgets/dialog.dart';
import 'package:flutter_vant_kit/widgets/divider.dart';
import 'package:flutter_vant_kit/widgets/field.dart';
import 'package:flutter_vant_kit/widgets/goodsAction.dart';
import 'package:flutter_vant_kit/widgets/imagePreview.dart';
import 'package:flutter_vant_kit/widgets/imageWall.dart';
import 'package:flutter_vant_kit/widgets/list.dart';
import 'package:flutter_vant_kit/widgets/loading.dart';
import 'package:flutter_vant_kit/widgets/noticeBar.dart';
import 'package:flutter_vant_kit/widgets/numberKeyboard.dart';
import 'package:flutter_vant_kit/widgets/pagination.dart';
import 'package:flutter_vant_kit/widgets/panel.dart';
import 'package:flutter_vant_kit/widgets/passwordInput.dart';
import 'package:flutter_vant_kit/widgets/picker.dart';
import 'package:flutter_vant_kit/widgets/price.dart';
import 'package:flutter_vant_kit/widgets/progress.dart';
import 'package:flutter_vant_kit/widgets/radioGroup.dart';
import 'package:flutter_vant_kit/widgets/rate.dart';
import 'package:flutter_vant_kit/widgets/search.dart';
import 'package:flutter_vant_kit/widgets/sidebar.dart';
import 'package:flutter_vant_kit/widgets/skeleton.dart';
import 'package:flutter_vant_kit/widgets/stepper.dart';
import 'package:flutter_vant_kit/widgets/steps.dart';
import 'package:flutter_vant_kit/widgets/submitBar.dart';
import 'package:flutter_vant_kit/widgets/swipe.dart';
import 'package:flutter_vant_kit/widgets/tag.dart';
import 'package:flutter_vant_kit/widgets/treeSelect.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
38
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
68
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health issues and suggestions

Document public APIs. (-0.02 points)

1199 out of 1241 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/widgets/checkbox.dart. (-0.50 points)

Analysis of lib/widgets/checkbox.dart reported 1 hint:

line 4 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: NCheckbox.value

Fix lib/widgets/collapseItem.dart. (-0.50 points)

Analysis of lib/widgets/collapseItem.dart reported 1 hint:

line 7 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: CollapseItem.isExpanded

Fix lib/widgets/list.dart. (-0.50 points)

Analysis of lib/widgets/list.dart reported 1 hint:

line 7 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: NList.finished, NList.error

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0
flutter 0.0.0
multi_image_picker ^4.6.0 4.6.1
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test