flutter_utils 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 14

flutter_utils #

flutter common utils

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.


  • flutter common utils, it based on AndroidUtilCode on android platform, and Currently, ios platform is not supported.Support for ios will be added later.


import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:flutter_utils/flutter_utils.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  _MyAppState createState() => _MyAppState();

class _MyAppState extends State<MyApp> {
  String _appVersionName = 'Unknown';
  String _appVersionCode = 'Unknown';
  String _androidId = 'Unknown';
  bool _isAppDebug = false;

  initState() {

  initPlatformState() async {
    String appVersionName = 'Unknown';
    String appVersionCode = 'Unknown';
    String androidId = 'Unknown';
    bool isAppDebug = false;
    try {
      appVersionName = await FlutterUtils.appVersionName;
      appVersionCode = await FlutterUtils.appVersionCode;
      androidId = await FlutterUtils.androidId;
      isAppDebug = await FlutterUtils.isAppDebug;
    } on PlatformException {
      appVersionName = 'Failed to get platform version.';
      appVersionCode = 'Failed to get platform version.';
      androidId = 'Failed to get platform version.';
    if (!mounted) return;

    setState(() {
      _appVersionName = appVersionName;
      _appVersionCode = appVersionCode;
      _androidId = androidId;
      _isAppDebug = isAppDebug;

  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: Text('Plugin example app'),
        body: Center(
          child: Column(
            mainAxisAlignment: MainAxisAlignment.center,
            children: <Widget>[
              Text('android id: $_androidId'),
              Text('app version name: $_appVersionName'),
              Text('app verison code: $_appVersionCode'),
              Text('app is debug: $_isAppDebug'),

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_utils: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_utils/flutter_utils.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0