flutter_util 0.0.6

  • Readme
  • Changelog
  • Example
  • Installing
  • 60

flutter_util #

Some common widgets and functions.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/README.md

meiqia_plugin_example #

Demonstrates how to use the meiqia_plugin plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_util: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_util/models.dart';
import 'package:flutter_util/utils.dart';
import 'package:flutter_util/widgets.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
38
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
60
Learn more about scoring.

We analyzed this package on Dec 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.1+4
  • Flutter: 1.12.13+hotfix.4

Health suggestions

Fix lib/src/utils/print.dart. (-1 points)

Analysis of lib/src/utils/print.dart reported 2 hints:

line 1 col 8: Unused import: 'dart:ui'.

line 3 col 8: Unused import: 'package:flutter/foundation.dart'.

Fix lib/src/utils/tool.dart. (-1 points)

Analysis of lib/src/utils/tool.dart reported 2 hints:

line 1 col 8: Unused import: 'dart:ui'.

line 5 col 8: Unused import: 'package:flutter_util/src/utils/common.dart'.

Fix lib/src/models/button_model.dart. (-0.50 points)

Analysis of lib/src/models/button_model.dart reported 1 hint:

line 1 col 8: Unused import: 'dart:ui'.

Fix additional 10 files with analysis or formatting issues. (-0.50 points)

Additional issues in the following files:

  • lib/src/widgets/text.dart (1 hint)
  • lib/models.dart (Run flutter format to format lib/models.dart.)
  • lib/src/models/image_model.dart (Run flutter format to format lib/src/models/image_model.dart.)
  • lib/src/models/text_model.dart (Run flutter format to format lib/src/models/text_model.dart.)
  • lib/src/utils/common.dart (Run flutter format to format lib/src/utils/common.dart.)
  • lib/src/utils/convert.dart (Run flutter format to format lib/src/utils/convert.dart.)
  • lib/src/widgets/button.dart (Run flutter format to format lib/src/widgets/button.dart.)
  • lib/src/widgets/image.dart (Run flutter format to format lib/src/widgets/image.dart.)
  • lib/utils.dart (Run flutter format to format lib/utils.dart.)
  • lib/widgets.dart (Run flutter format to format lib/widgets.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (intl).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
cached_network_image ^1.0.0 1.1.3 2.0.0-rc.1
flutter 0.0.0
intl ^0.15.5 0.15.8 0.16.0
json_annotation ^3.0.0 3.0.0
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
crypto 2.1.4
flutter_cache_manager 1.1.3
http 0.12.0+2
http_parser 3.1.3
meta 1.1.8
path 1.6.4
path_provider 1.5.1
pedantic 1.9.0
platform 2.2.1
sky_engine 0.0.99
source_span 1.5.5
sqflite 1.1.8 1.2.0-dev.1
string_scanner 1.0.5
synchronized 2.1.1
term_glyph 1.1.0
typed_data 1.1.6
uuid 2.0.4
vector_math 2.0.8
Dev dependencies
build_runner ^1.0.0
flutter_test
json_serializable ^3.2.0