flutter_unity_ads 0.0.2

flutter_unity_ads #

flutter_unity_ads plugin.

Version #

Android: 3.2.0 Ios: 3.1.0

Getting Started #

To implement UnityAdsListener

class _MyAppState extends State<MyApp> with UnityAdsListener {

To initialize and show ads.

FlutterUnityAds.initialize('124124', '18660', this, testMode: true);
FlutterUnityAds.show();

Note: 124124 is android game id test 18660 is ios game id test

0.0.1 #

  • TODO: Describe initial release.

example/README.md

flutter_unity_ads #

Demonstrates how to use the flutter_unity_ads plugin.

Getting Started #

To implement UnityAdsListener

class _MyAppState extends State<MyApp> with UnityAdsListener {

To initialize and show ads.

FlutterUnityAds.initialize('124124', '18660', this, testMode: true);
FlutterUnityAds.show();

Note: 124124 is android game id test 18660 is ios game id test

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_unity_ads: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_unity_ads/flutter_unity_ads.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
15
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

44 out of 44 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test