flutter_unipay_plugin 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 42

flutter_unipay_plugin #

License: MIT


使用说明 #

  • 请参考Flutter文档,了解plugin的一般用法
  • 本插件在iOS platform集成时,由于银联静态库存在C++/ObjC混编,因此需要在你的Flutter工程内使用到银联API的地方,使用ObjectC++混编,具体请参考example里的ios工程配置

欢迎支持 #

0.0.1 #

  • 2018-11-30 银联全渠道产品-手机控件支付集成的flutter插件,能够正常发起支付,并通过BinaryMessage向插件调用一端返回结果


flutter_unipay_plugin_example #

Demonstrates how to use the flutter_unipay_plugin plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_unipay_plugin: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_unipay_plugin/flutter_unipay_plugin.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Format lib/flutter_unipay_plugin.dart.

Run flutter format to format lib/flutter_unipay_plugin.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (dio).

Documentation URL doesn't exist. (-10 points)

At the time of the analysis the documentation field https://github.com/delapecci/flutter_unipay_plugin/doc/api/index.html was unreachable.

Package is getting outdated. (-12.33 points)

The package was last published 58 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
dio ^1.0.9 1.0.17 3.0.8
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
cookie_jar 0.0.8 1.0.1
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8