flutter_umplus 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 79

flutter_umplus #

一个简单的友盟 umeng app+ 统计,其他几个库的坑都踩过了,吸收了它们的优点,建议大家有这个库。

目前遇到的问题:

  • dispose 在Android有点问题,需要再测试一下,友盟必须在beginPageView和endPageView配对才算有效。如果有人知道如何解决欢迎fork。

Getting Started #

Init
key友盟AppKey
channel渠道;空字符串或者null,iOS默认为AppStore,Android字段从AnroidMainfest.xml的UMENG_CHANNEL读取
reportCrash是否报告错误
logEnable是否启用日志
encrypt是否启用加密

Usage #

初始化

FlutterUmplus.init(
    'Your umeng appkey',
    channel: 'Your channel',
    reportCrash: false,
    logEnable: true,
    encrypt: true,
);

页面开始

@override
void initState() {
	super.initState();
	
	FlutterUmplus.beginPageView('demo');

}

页面结束

@override
void dispose() {
	FlutterUmplus.endPageView('demo');
	// FIXME 这个最好放在最后,iOS有效,Android无论如何都无效。
	super.dispose();
}

事件埋点

FlutterUmplus.event('eventName', label: 'eventLabel');

仓库地址

LICENSE #

MIT

0.0.1 #

  • TODO: Describe initial release.

example/README.md

flutter_umplus_example #

Demonstrates how to use the flutter_umplus plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_umplus: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_umplus/flutter_umplus.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
73
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
62
Overall:
Weighted score of the above. [more]
79
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/flutter_umplus.dart.

Run flutter format to format lib/flutter_umplus.dart.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test