flutter_twitter_bootstrap 1.0.1-dev.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 49

flutter_twitter_bootstrap #

A Flutter Web Theme based on Twitter Bootstrap.

Become a contributor #

Slack group destined to its project developers

Run it #

Start by cloning the project locally

$ git clone git@github.com:marcobraghim/flutter_twitter_bootstrap.git

Change the Flutter git repository branch to the master and upgrade it. It may take a long time...

$ flutter channel master
$ flutter upgrade

Enable the Flutter Web Support

$ flutter config --enable-web

Walk into the repository folder

$ cd flutter_twitter_bootstrap/
$ flutter create .

Run it. Google Chrome required

$ flutter run -d chrome

Help #

Try to get some help here firstly.

[1.0.1-dev] - 2019-10-16 #

  • First publish

[1.0.1-dev.1] - 2019-10-16 #

  • Minimal details

[1.0.1-dev.2] - 2019-10-16 #

  • Minimal details


Examples #

Here we will provide some examples

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_twitter_bootstrap: ^1.0.1-dev.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_twitter_bootstrap/components/button/button.dart';
import 'package:flutter_twitter_bootstrap/components/button/ftcolors.dart';
import 'package:flutter_twitter_bootstrap/ftbootstrap.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1
  • Flutter: 1.17.3

Analysis suggestions

Package not compatible with SDK dart

because of import path [flutter_twitter_bootstrap]

Health suggestions

Format lib/components/button/button.dart.

Run flutter format to format lib/components/button/button.dart.

Maintenance suggestions

Package is pre-release. (-5 points)

Pre-release versions should be used with caution; their API can change in breaking ways.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies