flutter_twitter_ab 1.1.1

  • Readme
  • Changelog
  • Example
  • Installing
  • new65

flutter_twitter_ab #

A Flutter plugin for using the native TwitterKit SDKs on Android and iOS.

This plugin uses the new Gradle 4.1 and Android Studio 3.0 project setup.

Dart support #

  • Dart 1: 1.0.x.
  • Dart 2: 1.1.0 and up.

Installation #

See the installation instructions on pub. No platform-specific configuration is needed!

How do I use it? #

Here's some sample code that should cover most of the cases. For full API reference, just see the source code. Everything is documented there.

var twitterLogin = new TwitterLogin(
  consumerKey: '<your consumer key>',
  consumerSecret: '<your consumer secret>',
);

final TwitterLoginResult result = await twitterLogin.authorize();

switch (result.status) {
  case TwitterLoginStatus.loggedIn:
    var session = result.session;
    _sendTokenAndSecretToServer(session.token, session.secret);
    break;
  case TwitterLoginStatus.cancelledByUser:
    _showCancelMessage();
    break;
  case TwitterLoginStatus.error:
    _showErrorMessage(result.error);
    break;
}

1.1.1 #

  • Fixed problem with building iOS project: s.static_framework = true set in .podspec file.

1.1.0 #

  • Dart 2 support! There should not be any breaking changes. Please do file issues if you have problems.

1.0.1 #

  • Fixed onActivityResult override that was potentially preventing other plugins from receiving Activity results.
  • Fixed a logout crash on Android in the case when the user wasn't already logged in.
  • Fixed #1 by returning NSNull from the sessionToMap method when the twitter session is nil.
  • Fix #2 by clarifying the documentation. Also explain the toMap and fromMap methods of TwitterSession more clearly.

1.0.0 #

  • Initial release.

example/README.md

flutter_twitter_ab_example #

Demonstrates how to use the flutter_twitter_ab plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_twitter_ab: ^1.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_twitter_ab/flutter_twitter_ab.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
30
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Oct 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/flutter_twitter_ab.dart.

Run flutter format to format lib/flutter_twitter_ab.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test