flutter_tindercard 0.1.4

  • README.md
  • Example
  • Installing
  • Versions
  • 86

flutter_tindercard #

Tinder Card Widget.

Screenshots #


Getting Started #

  1. Depend on it by adding this to your pubspec.yaml file: flutter_tindercard: ^0.1.1

  2. Import it: import 'package:flutter_tindercard.dart'

  3. Add TinderSwapCard in your widget layout and write the single card layout builder you need, then you get a Tinder(探探) like swap card widget!

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.


import 'package:flutter/material.dart';
import 'package:flutter_tindercard/flutter_tindercard.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      home: ExampleHomePage(),

class ExampleHomePage extends StatefulWidget {
  _ExampleHomePageState createState() => _ExampleHomePageState();

class _ExampleHomePageState extends State<ExampleHomePage>
    with TickerProviderStateMixin {

  List<String> welcomeImages = [

  Widget build(BuildContext context) {
    return new Scaffold(
      body: new Center(
          child: Container(
              height: MediaQuery.of(context).size.height * 0.6,
              child: new TinderSwapCard(
                orientation: AmassOrientation.BOTTOM,
                totalNum: 6,
                stackNum: 3,
                maxWidth: MediaQuery.of(context).size.width * 0.9,
                maxHeight: MediaQuery.of(context).size.width * 0.9,
                minWidth: MediaQuery.of(context).size.width * 0.8,
                minHeight: MediaQuery.of(context).size.width * 0.8,
                cardBuilder: (context, index) => Card(
                      child: Image.asset('${welcomeImages[index]}'),

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_tindercard: ^0.1.4

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_tindercard/flutter_tindercard.dart';
Version Uploaded Documentation Archive
0.1.4 Mar 19, 2019 Go to the documentation of flutter_tindercard 0.1.4 Download flutter_tindercard 0.1.4 archive
0.1.3 Mar 19, 2019 Go to the documentation of flutter_tindercard 0.1.3 Download flutter_tindercard 0.1.3 archive
0.1.2 Mar 18, 2019 Go to the documentation of flutter_tindercard 0.1.2 Download flutter_tindercard 0.1.2 archive
0.1.1 Mar 18, 2019 Go to the documentation of flutter_tindercard 0.1.1 Download flutter_tindercard 0.1.1 archive
0.1.0 Mar 18, 2019 Go to the documentation of flutter_tindercard 0.1.0 Download flutter_tindercard 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/flutter_tindercard.dart. (-0.50 points)

Analysis of lib/flutter_tindercard.dart reported 1 hint:

line 10 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: TinderSwapCard._cardBuilder, TinderSwapCard._totalNum, TinderSwapCard._stackNum, TinderSwapCard.swipeCompleteCallback, TinderSwapCard.swipeUpdateCallback

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies