flutter_tim_plugin 0.0.5
flutter_tim_plugin: ^0.0.5 copied to clipboard

Flitter im Library Based on Tencent cloud im encapsulation realizes most common functions

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add flutter_tim_plugin

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  flutter_tim_plugin: ^0.0.5

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:flutter_tim_plugin/common_define.dart';
import 'package:flutter_tim_plugin/message/conversation.dart';
import 'package:flutter_tim_plugin/message/custom_message.dart';
import 'package:flutter_tim_plugin/message/emoji_message.dart';
import 'package:flutter_tim_plugin/message/file_message.dart';
import 'package:flutter_tim_plugin/message/image_message.dart';
import 'package:flutter_tim_plugin/message/location_message.dart';
import 'package:flutter_tim_plugin/message/message.dart';
import 'package:flutter_tim_plugin/message/message_content.dart';
import 'package:flutter_tim_plugin/message/message_factory.dart';
import 'package:flutter_tim_plugin/message/sound_message.dart';
import 'package:flutter_tim_plugin/message/text_message.dart';
import 'package:flutter_tim_plugin/message/video_message.dart';
import 'package:flutter_tim_plugin/tim_flutter_plugin.dart';
import 'package:flutter_tim_plugin/tim_method_key.dart';
import 'package:flutter_tim_plugin/util/type_util.dart';
3
likes
70
pub points
0%
popularity

Publisher

erdongerzhong.wang

Flitter im Library Based on Tencent cloud im encapsulation realizes most common functions

Repository (GitHub)
View/report issues

Documentation

API reference

License

LICENSE

Dependencies

flutter

More

Packages that depend on flutter_tim_plugin