flutter_star_rating 0.0.3

  • Readme
  • Changelog
  • Installing
  • 78

flutter_star_rating #

Flutter Star Rating widget based on Canvas.

Features #

  • Supports decimal numbers: 4.5, 3.4, 2.75, ...
  • Only display mode / Interactive mode
  • Customizable:
    • Fill color
    • Stroke color
    • Stroke width
    • Star Rays Count (default 5)
    • Empty color
    • Star size

Installation #

1. Depend

Add this to you package's pubspec.yaml file:

dependencies:
  flutter_star_rating: ^0.0.2

2. Install

Run command:

$ flutter packages get

3. Import

Import in Dart code:

import 'package:flutter_star_rating/flutter_star_rating.dart';

Usage #

Simple display rating

StarRating(rating: 3.75),

For interactive

double rating = 0.0;
...
StarRating(
  rating: rating,
  onChangeRating: (int rating) {
    setState(() {
      this.rating = rating.toDouble();
    });
  },
)

Customize

StarRating(
  rating: 3.0,
  starConfig: StarConfig(
    fillColor: Colors.red,
    // other props
  )
)

StarConfig - is data class, constructor params:

NameTypedefaults
fillColorColorColors.yellow
strokeColorColorColors.black
strokeWidthdouble1.0
raysCountint5
emptyColorColorColors.white
sizedouble50.0

Full App Example #

import 'package:flutter/material.dart';
import 'package:flutter_star_rating/flutter_star_rating.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'My App',
      home: MyHomePage(title: 'Flutter Star Rating Page'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  double rating = 3.5;

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      body: Center(
        child: StarRating(
          rating: rating,
          onChangeRating: (int rating) {
            setState(() {
              this.rating = rating.toDouble();
            });
          },
        ),
      ),
    );
  }
}

TODO #

  • Custom Stars count
  • Rounded stars

[0.0.1] - 03.04.2019

  • First release.

[0.0.2] - 03.04.2019

  • StarConfig in constructor is optional

[0.0.3] - 03.04.2019

  • Update README.md

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_star_rating: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_star_rating/flutter_star_rating.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
70
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
63
Overall:
Weighted score of the above. [more]
78
Learn more about scoring.

We analyzed this package on Nov 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/flutter_star_rating.dart.

Run flutter format to format lib/flutter_star_rating.dart.

Maintenance suggestions

The package description is too short. (-17 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_star_rating.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test