flutter_spotlight 0.1.1

flutter_spotlight #

Spotlight for Flutter that lights items for tutorials etc...

pub package

Simple Example #

class _MyHomePageState extends State<MyHomePage> {
  Offset _center = Offset(100.0, 100.0); // Center position of Spotlight
  double _radius = 50.0; // Radius of Spotlight

  @override
  Widget build(BuildContext context) {
    return Spotlight(
      center: _center,
      radius: _radius,
      child: new Scaffold(
        appBar: new AppBar(
          title: new Text(widget.title),
          actions: <Widget>[
            IconButton(
              icon: Icon(Icons.search),
              onPressed: () {},
            ),
          ],
        ),
        body: SafeArea(
          child: Container(),
        ),
        floatingActionButton: FloatingActionButton(
          child: Icon(Icons.favorite_border),
          onPressed: () {},
        ),
      ),
    );
  }
}

For details see the example app

Showcase from example app #

capture

[0.1.1]

  • FIx invalid override.
  • Add analyzer options with enableSuperMixins.

[0.1.0]

  • Modify details.
  • Add Movable Demo.

[0.0.2]

  • Add spotlight animation.

[0.0.1]

  • Initial release.

example/README.md

flutter_spotlight_example #

A new Flutter project.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_spotlight: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_spotlight/flutter_spotlight.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
58
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
79
Learn more about scoring.

We analyzed this package on Sep 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test