flutter_sensors_analytics_plugin 0.1.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 54

flutter_sensors_analytics_plugin #

pub packages LICENSE


使用前请先了解神策分析 Android SDK使用说明, iOS SDK使用说明


  1. 在 project 级别的 build.gradle 文件中添加 Sensors Analytics android-gradle-plugin 依赖:

     //添加神策分析 android-gradle-plugin 依赖
     classpath 'com.sensorsdata.analytics.android:android-gradle-plugin2:2.1.0'
  2. 在 主 module 的 build.gradle 文件中添加 com.sensorsdata.analytics.android 插件:

     //添加 com.sensorsdata.analytics.android 插件
     apply plugin: 'com.sensorsdata.analytics.android'
  3. 由于 SDK 会依赖 appcompat-v7 需要添加下面依赖( 如果项目中已引入了 v7包,可以不添加 ):

     implementation "com.android.support:appcompat-v7:$rootProject.supportLibraryVersion"

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.1.2 #

  • fix properties null

0.1.1 #

  • update readme

0.1.0 #

  • add doc

0.0.3 #

  • add doc

0.0.2 #

  • fix

0.0.1 #

  • init


flutter_sensors_analytics_plugin_example #

Demonstrates how to use the flutter_sensors_analytics_plugin plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_sensors_analytics_plugin: ^0.1.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_sensors_analytics_plugin/flutter_sensors_analytics_plugin.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 17, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Maintenance suggestions

Package is getting outdated. (-7.95 points)

The package was last published 56 weeks ago.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8