flutter_search_panel 1.0.1

Flutter Search Panel #

pub package

A Widget to allow users to search from a list of string and make a selection (Similar to a DropDownButtom).

Installing #

dependencies:
  flutter_search_panel: ^1.0.1

Import #

import 'package:flutter_search_panel/flutter_search_panel.dart';

How To Use #

List<SearchItem<int>> data = [
  SearchItem(0, 'This'),
  SearchItem(1, 'is'),
  SearchItem(2, 'a'),
  SearchItem(3, 'test'),
  SearchItem(4, '.'),
];

FlutterSearchPanel<int>(
  padding: EdgeInsets.all(10.0),
  selected: 3,
  title: 'Demo Search Page',
  data: data,
  icon: new Icon(Icons.check_circle, color: Colors.white),
  color: Colors.blue,
  textStyle: new TextStyle(color: Colors.white, fontWeight: FontWeight.bold, fontSize: 20.0, decorationStyle: TextDecorationStyle.dotted),
  onChanged: (int value) {
    print(value);
  },
),

Screenshots #

alt text alt text

Bugs & Requests

If you encounter any bugs feel free to open an issue. Raise a ticket on github for suggestions. Pull request are also welcome.

Flutter #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

License #

MIT License

0.0.1 #

  • Initial commit

0.0.2 #

  • Updating docs
  • Maintenance (Search page title fix)

1.0.0 #

  • First stable release
  • Description Update

1.0.1 #

  • Added Dynamic data

example/README.md

flutter_search_panel_example #

Demonstrates how to use the flutter_search_panel plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_search_panel: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_search_panel/flutter_search_panel.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
82
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
91
Learn more about scoring.

We analyzed this package on Sep 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/search_item.dart.

Run flutter format to format lib/search_item.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test