flutter_repository 1.1.0

  • Readme
  • Changelog
  • Installing
  • 57

DDD repositories for Flutter #

Collection-oriented implementation of DDD repositories.

Why flutter_repositories? #

This project should help you better integrate object-oriented principles into your applications, by facilitating modeling of your application's domain model, creating classes, that represent actual concepts of your domain model, which are understood even by your end-users.

Check out examples from implementations of flutter_repository:

[1.1.0] #

Add a mock class for SimpleCollection, so that library users would not have to make such mock themselves every time.

[1.0.0] #

Initial release.

[1.0.0-dev.7] #

Made Specification immutable.

[1.0.0-dev.6] #

Made PrivateImmutableCollection and PrivateCollection proxies to actual ImmutableCollection and Collection implementations.

[1.0.0-dev.5] #

Introduce PrivateCollection amd PrivateImmutableCollection.

[1.0.0-dev.4] #

Fix DataSourceServant type definition in _BaseCollection, ImmutableCollection and Collection.

[1.0.0-dev.3] #

Added ordering support for results of Specification.

[1.0.0-dev.2] #

Create a separate ReadonlyDataSource abstraction, so that data sources that only allow querying would not have to implement modifiable DataSource class.

[1.0.0-dev.1] #

Initial implementation of collection oriented repositories with no actual implementations at the moment.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_repository: ^1.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_repository/flutter_repository.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
26
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on Feb 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Format lib/flutter_repository.dart.

Run flutter format to format lib/flutter_repository.dart.

Format lib/src/collection.dart.

Run flutter format to format lib/src/collection.dart.

Format lib/src/data.dart.

Run flutter format to format lib/src/data.dart.

Format lib/src/mocks.dart.

Run flutter format to format lib/src/mocks.dart.

Format lib/src/specification.dart.

Run flutter format to format lib/src/specification.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_repository.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
mockito ^4.1.1 4.1.1
Transitive dependencies
async 2.4.0
boolean_selector 2.0.0
charcode 1.1.3
collection 1.14.11 1.14.12
matcher 0.12.6
meta 1.1.8
path 1.6.4
sky_engine 0.0.99
source_span 1.6.0
stack_trace 1.9.3
stream_channel 2.0.0
string_scanner 1.0.5
term_glyph 1.1.0
test_api 0.2.14
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
class_test ^1.0.0
flutter_test