flutter_qrscaner 0.0.3

flutter_qrscaner #

LICENSE Badge

功能 #

  • 打开二维码扫码界面并返回扫码结果(目前只支持android端)

Demo #

下载 APK-Demo

用法 #

1.在 pubspec.yaml 中添加依赖 #

dependencies:
  flutter_qrscaner: ^0.0.3

2.在AndroidManifest.xml添加相机权限 #

<uses-permission android:name="android.permission.CAMERA" />

3.在按钮点击事件里调用 #

import 'package:flutter_qrscaner/flutter_qrscaner.dart';
....
  RaisedButton(
    onPressed: () {
      FlutterQrscaner.startScan().then((value) {
        setState(() {
          _qrContent = value;
        });
      });
    },
    child: Text('开始扫码')),

TODO #

  • IOS端支持(IOS不会,求帮助)
  • 闪光灯
  • 识别相册里的二维码
  • 提供更多可供配置的选项参数

0.0.1 #

  • 第一版发布

0.0.2 #

  • 添加描述和例子

0.0.3 #

  • 修改调用方法

example/README.md

功能 #

  • 打开二维码扫码界面并返回扫码结果(目前只支持android端)

Demo #

下载 APK-Demo

用法 #

1.在 pubspec.yaml 中添加依赖 #

dependencies:
  flutter_qrscaner: ^0.0.3

2.在AndroidManifest.xml添加相机权限 #

<uses-permission android:name="android.permission.CAMERA" />

3.在按钮点击事件里调用 #

import 'package:flutter_qrscaner/flutter_qrscaner.dart';
....
  RaisedButton(
    onPressed: () {
      FlutterQrscaner.startScan().then((value) {
        setState(() {
          _qrContent = value;
        });
      });
    },
    child: Text('开始扫码')),

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_qrscaner: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_qrscaner/flutter_qrscaner.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
50
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
69
Learn more about scoring.

We analyzed this package on Aug 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

4 out of 4 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flutter_qrscaner.dart.

Run flutter format to format lib/flutter_qrscaner.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test