flutter_proxy 0.1.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 67

flutter_proxy #

A flutter plugin to read network proxy info from native. It can be used to set up the network proxy for flutter.

Installing #

You should add the following to your pubspec.yaml file:

dependencies:
  flutter_proxy: ^0.1.0

Example #

final settings = await FlutterProxy.proxySetting;
bool enabled = settings.enabled;
String host = settings.host;
int port = settings.port;

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.1.2 #

  • fix bug。

0.1.0 #

  • Add Description。

0.0.1 #

  • Support get device proxy。

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:flutter_proxy/flutter_proxy.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _proxySetting = 'None';

  @override
  void initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    try {
      final settings = await FlutterProxy.proxySetting;
      _proxySetting = '${settings.host}:${settings.port}';
    } on PlatformException {
      _proxySetting = 'Failed to get proxy settings.';
    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {});
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Flutter Proxy Plugin'),
        ),
        body: Center(
          child: Text('Proxy Setting is: $_proxySetting\n'),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_proxy: ^0.1.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_proxy/flutter_proxy.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
34
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:flutter_proxy/flutter_proxy.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:flutter_proxy/flutter_proxy.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:flutter_proxy/flutter_proxy.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:flutter_proxy/flutter_proxy.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [flutter_proxy] that is in a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test