flutter_project_gen 1.0.0+1

  • Readme
  • Changelog
  • Installing
  • new53

template_gen #

A Flutter project generator

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_project_gen: ^1.0.0+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_project_gen/flutter_project_gen.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
27
Health:
Code health derived from static analysis. [more]
91
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [flutter_project_gen] that is in a package requiring null.

Health issues and suggestions

Document public APIs. (-0.84 points)

185 out of 186 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/project/theme.g.dart. (-4.89 points)

Analysis of lib/src/project/theme.g.dart reported 10 hints, including:

line 9 col 17: Name non-constant identifiers using lowerCamelCase.

line 31 col 22: Name non-constant identifiers using lowerCamelCase.

line 46 col 16: Name non-constant identifiers using lowerCamelCase.

line 53 col 22: Name non-constant identifiers using lowerCamelCase.

line 59 col 19: Name non-constant identifiers using lowerCamelCase.

Fix lib/src/project/project.g.dart. (-1 points)

Analysis of lib/src/project/project.g.dart reported 2 hints:

line 9 col 19: Name non-constant identifiers using lowerCamelCase.

line 41 col 22: Name non-constant identifiers using lowerCamelCase.

Fix lib/src/project/widget.g.dart. (-1 points)

Analysis of lib/src/project/widget.g.dart reported 2 hints:

line 9 col 17: Name non-constant identifiers using lowerCamelCase.

line 25 col 22: Name non-constant identifiers using lowerCamelCase.

Fix additional 6 files with analysis or formatting issues. (-1.50 points)

Additional issues in the following files:

  • lib/src/files/mobile.dart (1 hint)
  • lib/src/files/unsupported.dart (1 hint)
  • lib/src/project_files.dart (1 hint)
  • lib/flutter_project_gen.dart (Run flutter format to format lib/flutter_project_gen.dart.)
  • lib/src/project_constants.dart (Run flutter format to format lib/src/project_constants.dart.)
  • lib/src/template_gen.dart (Run flutter format to format lib/src/template_gen.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (freezed_annotation).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_project_gen.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
archive ^2.0.13 2.0.13
flutter 0.0.0
freezed_annotation ^0.7.1 0.7.1 0.11.0
image_resizer ^1.0.2 1.0.2
logging ^0.11.4 0.11.4
path ^1.7.0 1.7.0
recase ^3.0.0 3.0.0
reflected_mustache ^1.0.11 1.0.11
Transitive dependencies
_fe_analyzer_shared 4.0.0 5.0.0
analyzer 0.39.10 0.39.11
args 1.6.0
async 2.4.1
build 1.3.0
build_config 0.4.2
build_daemon 2.1.4
build_resolvers 1.3.9
build_runner_core 5.2.0 6.0.0
built_collection 4.3.2
built_value 7.1.0
charcode 1.1.3
checked_yaml 1.0.2
code_builder 3.3.0
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
csslib 0.16.1
dart_style 1.3.6
fixnum 0.10.11
glob 1.2.0
graphs 0.2.0
html 0.14.0+3
http_multi_server 2.2.0
http_parser 3.1.4
image 2.1.13
io 0.3.4
js 0.6.2
json_annotation 3.0.1
matcher 0.12.8
meta 1.1.8
mime 0.9.6+3
node_interop 1.1.1
node_io 1.1.1
package_config 1.9.3
pedantic 1.9.0 1.9.1
petitparser 3.0.4
pool 1.4.0
pub_semver 1.4.4
pubspec_parse 0.1.5
quiver 2.1.3
reflectable 2.2.5
shelf 0.7.7
shelf_web_socket 0.2.3
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.5
stream_channel 2.0.0
stream_transform 1.2.0
string_scanner 1.0.5
term_glyph 1.1.0
timing 0.1.1+2
typed_data 1.1.6 1.2.0
vector_math 2.0.8
watcher 0.9.7+15
web_socket_channel 1.1.0
xml 3.7.0 4.2.0
yaml 2.2.1
Dev dependencies
build_runner ^1.7.1 1.10.0
build_version ^2.0.0
flutter_test
freezed ^0.10.2
settings_gen ^1.0.4