flutter_poplayer 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • new48

flutter_poplayer #

Left slide and slide up drawer effect. Compatible with Android & iOS.

Installation #

Add


flutter_swiper : ^lastest_version

to your pubspec.yaml ,and run

flutter packages get 

in your project's root directory.

Basic Usage #

Create a new project with command

flutter create myapp

Edit lib/main.dart like this:


import 'package:flutter/material.dart';

import 'package:flutter_poplayer/flutter_poplayer.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'flutter_poplayer demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(title: 'Flutter Demo Home Page'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  RightPopConfig _rightPopConfig;
  TopPopConfig _topPopConfig;
  final PoplayerController _controller = PoplayerController();
  @override
  void initState() {
    super.initState();
    _rightPopConfig = RightPopConfig(
        needRight: true,
        maxWidth: 240,
        backgroupColor: Colors.yellow,
        autoAnimDistance: 20,
        container: GestureDetector(
          child: Center(child: Text('点我收起')),
          onTap: () {
            _controller.autoToRight();
          },
        ));

    _topPopConfig = TopPopConfig(
        backgroupColor: Colors.red,
        needTop: true,
        topMaxHeight: 740,
        topAutoAnimDistance: 20,
        topMinHeight: 150,
        container: GestureDetector(
          child: Center(child: Text('点我收起')),
          onTap: () {
            _controller.autoToBottom();
          },
        ));
  }

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: Poplayer(
        rightPopConfig: _rightPopConfig,
        topPopConfig: _topPopConfig,
        controller: _controller,
        content: Container(
          child: Center(
            child: Text('content'),
          ),
        ),
      ),
    );
  }
}

[0.0.3] - TODO: Add release date.

  • UPDATE README.

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_poplayer: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_poplayer/flutter_poplayer.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Nov 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test